-
        

+ Antworten
Ergebnis 1 bis 8 von 8

Thema: schnellere Alternative zu l293d

  1. #1
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    25.02.2005
    Beiträge
    114

    schnellere Alternative zu l293d

    Anzeige

    SMARTPHONES & TABLETS-bis zu 77% RABATT-Kostenlose Lieferung-Aktuell | Cool | Unentbehrlich
    Hallo

    Ich brauch ganz dringend einen Treiber für zwei Motoren implementiert als H-Brücke das Projekt muss ganz dringend innerhalb der nächsten Woche fertig werden, das Problem das ich gerade hab ist das mir bei einer passenden PWM Frequenz fast die ohren wegfliegen. Ich brauch einen Treiber der mindestens mit 10 kHz arbeitet ambesten mehr, die Motoren brauchen 9Volt und wenn sie blockiert sind bis zu 1A laufen unter normaler belastung mit unter 500mA.

    Das Teil sollte gute Verfügbarkeit aufweisen, ambesten bei Conrad weil ich keine Zeit mehr habe etwas zu bestellen.

    flo1

  2. #2
    Gast
    Zitat Zitat von Datenblatt SGS zu L293D
    tr Rise Time (*) 0.1 to 0.9 VO 250 ns
    tf Fall Time (*) 0.9 to 0.1 VO 250 ns
    ton Turn-on Delay (*) 0.5 Vi to 0.5 VO 750 ns
    toff Turn-off Delay (*) 0.5 Vi to 0.5 VO 200 ns
    Ist Dein L293D defekt? Nur wegen der Bemerkung mit den Ohren.

    Zitat Zitat von flo1
    ... Ich brauch einen Treiber der mindestens mit 10 kHz arbeitet ambesten mehr ...
    Wenn Du misstrauisch bist, dass der L293D den max. Strom aushält - nimm zwei. Für jeden Motor einen - und schalte beide Kanäle jeweils parallel. Läuft bei mir bestens.

  3. #3
    Erfahrener Benutzer Robotik Visionär Avatar von oberallgeier
    Registriert seit
    01.09.2007
    Ort
    Oberallgäu
    Beiträge
    7.594
    Sorry - war nicht eingeloggt.
    Ciao sagt der JoeamBerg

  4. #4
    Gast
    naja offensichtlich funktioniert mein L293d für alle frequenzen bis 1kHz ganz orodentlich aber ich bin auf etwas höhere frequenzen angewiesen. wenn ich am enable eingang 6khz mit 50% duty cycle anlege höre ich nur ein 6kHz piepen und der Motor dreht sich keinen milimeter

  5. #5
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    25.02.2005
    Beiträge
    114
    Hallo nochmal

    Also mein Problem ist das ich das Projekt mit einem MOSFET als schalter bei einer PWM frequenz von 50kHz entwickelt habe, ich habe mich darauf eingestellt wohl mit der Frequenz auf 10kHz runter zu gehen, da funktioniert auch alles noch bei dem MOSFET herrvorragend, aber wenn ich meinen 10kHz an den L293D anlege höre ich nur ein fiepen aber der motor dreht sich kein bischen, dazu steh ich unter ziemlichen zeitdruck, ich hatte vor einfach nurnoch die drehbarkeit in beide Richtungen zu implementieren und jetzt das.

    flo1

  6. #6
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    25.02.2005
    Beiträge
    114
    Ah diese schaltung macht mich verrückt wenn ich mit einem 220K wiederstand die 5V schiene berühre bleibt der motor stehtn

  7. #7
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    15.11.2006
    Beiträge
    463
    Laut Datenblatt (ST) wird der L293D ja nur bis 5 kHz empfohlen. Von den genannten Anstiegszeiten her sollte die Verlustleistung aber auch bei 10 kHz kein Problem sein. Allerdings beziehen sich diese Angaben auf die Ansteuerung mit dem normalen Eingang und ohne Last. Möglicherweise dauert das Schalten mit Last jedoch deutlich länger, da die Transistoren einen hohen Laststrom liefern müssen und wegen der Induktiven Last (Motor) die Reverse-Recovery-Zeit der Dioden eine Rolle spielt (die beim L293D nicht weiter spezifiziert sind). Vielleicht helfen ein paar Shottky-Dioden parallel zu den im Chip integrierten Dioden. Es ist auch möglich, dass der Enable-Eingang deutlich langsamer als der normale Eingang schaltet.

    Wie gut funktioniert die Schaltung mit einer nicht induktiven Dummy-Last (z.B. 2 antiparallele LEDs + Vorwiderstand) statt dem Motor?

    Ach ja: Bei der Ansteuerung durch PWM an Enable ist es bei hinreichender PWM-Frequenz völlig normal, dass sich der Motor nicht dreht, solange das PWM-Verhältnis nicht deutlich größer als 50% ist. Während der Einschaltphase liegt eine positive Spannung (Betriebsspannung minus Spannungsabfall an Transistoren) an und der Strom steigt durch die Induktivität langsam an. Nach dem Abschalten der Transistoren fliesst der Strom erst einmal weiter durch die Freilaufdioden. Dabei liegt die negative Betriebsspannung (plus die Durchlassspannung der Dioden) am Motor an. Wenn das PWM-Tastverhältnis zu gering ist, sinkt der Strom wieder auf Null und beim nächsten Durchgang beginnt der Anstieg des Stroms wieder bei Null. Je höher die PWM-Frequenz ist, desto geringer ist der durch die Motorinduktivität erreichbare Strom. Für das Drehmoment am Motor (und damit das Anlaufen) ist der mittlere Strom entscheidend. Bei hoher PWM-Frequenz ist dieser mittlere Strom jedoch sehr gering, wenn der Strom in der Ausschaltphase immer auf Null sinkt. Bei einer PWM-Rate von deutlich über 50% sinkt der Strom in der Ausschaltphase nicht mehr auf Null und so kann sich über mehrere Einschaltphasen der Strom aufbauen, der zum Loslaufen des Motors nötig ist. Läuft der Motor an, wenn du das PWM-Verhältnis auf z.B. 70% erhöhst?

  8. #8
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    25.02.2005
    Beiträge
    114
    Hallo

    Vielen Dank für die Hilfe, ich hatte leider keine Zeit eher zu antworten.
    Ich habe das Projekt erfolgreich abgeschlossen

    flo1

+ Antworten

Berechtigungen

  • Neue Themen erstellen: Ja
  • Themen beantworten: Ja
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •