-         

Ergebnis 1 bis 5 von 5

Thema: L5973: VOut = VIn; Regelt nicht?

  1. #1
    Erfahrener Benutzer Robotik Einstein Avatar von Jaecko
    Registriert seit
    16.10.2006
    Ort
    Lkr. Rottal/Inn
    Alter
    35
    Beiträge
    1.987

    L5973: VOut = VIn; Regelt nicht?

    Anzeige

    Moin.

    Hab mir mit einem L5973 ein "Netzteil" für 5-12V in, 3,3V Out gebaut; Vorlage hierfür war die Schaltung im Datenblatt ( http://www.st.com/stonline/books/pdf/docs/8588.pdf ) auf der ersten Seite (siehe auch Anhang hier)

    Problem nun: Die Ausgangsspannung entspricht der Eingangsspannung.
    Kurzschlüsse etc. sind nicht vorhanden; Leiterbahnen haben auch keine Haarrisse; alles mehrmals nachgemessen.

    Weiterhin ist die VREF, die ja eigentlich 3,3V sein sollte, tatsächlich nur 0,2V; also der Regler hat schon ein Problem damit, die 3,3V VREF zur Verfügung zu stellen.

    Am Feedback-Pin liegen bei 5V Eingangsspannung über den Spannungsteiler ca. 1,88V an. Eigentlich sollte der Regler ja dann soweit runterregeln, dass an Feedback ca. 1,23V anliegen: 1,23 / 1,88 * 5V = ~3,3V.

    Wird die Eingangsspannung erhöht, erwärmt sich der Regler sehr stark; ab ca. 10V ist anfassen nicht mehr möglich (einzige angeschlossene Last: Multimeter für Ausgangsspannung)

    Kennt jemand so ein Verhalten eines Schaltreglers, bei dem er "vollgas" regelt?

    mfG


    Edit: Anhang aus Platzgründen entfernt
    #ifndef MfG
    #define MfG

  2. #2
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    07.07.2006
    Ort
    Mannheim
    Beiträge
    454
    Entweder ist ein Wurm in deiner Schaltung, oder das Ding ist im Eimer. Ic nicht beschalten, nur Versorgungsspannung VCC, gnd, inh evtl. comp. Wenn dann Vref nicht stimmt isser hin. (Alles direkt im IC messen).

  3. #3
    Erfahrener Benutzer Robotik Einstein Avatar von Jaecko
    Registriert seit
    16.10.2006
    Ort
    Lkr. Rottal/Inn
    Alter
    35
    Beiträge
    1.987
    Tatsache... also mit der Minimalbeschaltung liefert ein "frischer" die 3,3V Referenz. Eingelötet, läuft. Der andere ist vermutlich tatsächlich thermisch getötet worden.
    #ifndef MfG
    #define MfG

  4. #4
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    07.07.2006
    Ort
    Mannheim
    Beiträge
    454
    Na also. Geht doch. Dazu ein gaaanz alter Trick: Finger aufs IC. Wenn sich dann eine Brandblase bildet, ist es höchste Zeit über Kühlkörper nachzudenken

  5. #5
    Neuer Benutzer
    Registriert seit
    29.11.2011
    Ort
    Krakau
    Beiträge
    1

    Probleme mit L5973

    Have Jaecko
    Mit dem L5973 hab ich seit langem zu tun. Es war ein genialer Ersatz für LM7805 aber Probleme hat er mit sich auch gebracht.
    Es passiert ganz oft dass die Ausgangsspannung entspricht der Eingangsspannung und bei mir heißt es 12V Ausgangsspannung die ein paar ICs schon getötet hat. Bis heute weiß ich nicht warum das passiert, ich habe ST Application Notes gefolgt, alle Komponente gecheckt alles ist ok. Weil ich L5973 in Serienproduktion benutze habe ich ein Jumper eingesetzt und überprüfe die Ausgangsspannung von L5973 bevor ich den Jumper kurzschließe.

    Im Internet habe Ich so was gefunden: http://www.qsl.net/va3diw/junk.html. Zitat: "ST Micro doesn't know how to make switched power supply chips. The worst exapmles are L5973, L598x, A597x (20 Volt transients). A while ago I was asked to investigate reason why about 20 new communication boards failed. The new boards connected to the power supply started bahaving funny, or haven't worked at all. Well, there were 20 Volt transients coming from the power supply directly to the +5 Volt Philips communication chip.. ST Micro switcher chips have wrong feedback design."

    Bei mir ca. Einer von 30 L5973 geht kaputt, vielleicht hast du einfach Pech gehabt...

    MFG
    Tomasz

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •