-
        

Ergebnis 1 bis 4 von 4

Thema: Polin Schrittmotorplatine ansteuern

  1. #1

    Polin Schrittmotorplatine ansteuern

    Anzeige

    SMARTPHONES & TABLETS-bis zu 77% RABATT-Kostenlose Lieferung-Aktuell | Cool | Unentbehrlich
    Hallo Leute,

    ich habe ein kleines Projekt geplant, für das ich einen Schrittmotor benötige. Da ich nicht viel Geld ausgeben möchte, habe ich mir die Polin Schrittmotorplatine bestellt und zusammengelötet. Soweit scheint mit der Platine auch alles in Ordnung zu sein, zumindest die Spannungen passen überall.

    Nun habe ich aber das Problem, dass ich die Platine nicht ansteuern kann. Zu Testzwecken habe ich das mitgelieferte Programm MotSTEP verwendet und die Platine an meinen LPT-Port angeschlossen. Allerdings führen alle Motorausgänge auf der Platine Spannung. Und ein Programmdurchlauf von MotSTEP führt zu keiner Änderung. Einen Fehler auf der Platine schließe ich aber erst einmal aus, da auch alle relevanten Ausgänge des LPT-Ports dauerhaft Spannung führen. Somit dachte ich, dass mein Port auf dem Motherboard defekt ist und kaufte mir eine neue LPT-PCI-Karte. Doch auch hier das gleiche Problem!

    Habe ich irgendwelche Einstellungen falsch? Was kann ich machen? Habt Ihr einen Tipp für mich?

    Gruß
    Ralph

  2. #2
    Erfahrener Benutzer Begeisterter Techniker Avatar von RobbyMartin
    Registriert seit
    31.12.2009
    Ort
    Leverkusen
    Alter
    24
    Beiträge
    206
    Ich kenne zwar das Programm nicht aber guck mal ob du irgenbdwo bei den einstellungen den lpt port auswählken kannst.

    Wenn das nicht geht lad dir einfach ne software mit der man die einzelnen pins des lpts ansteuern kann.

    Was mal bei meiner relaiskarte der Fehler war, das vom lpt stecker/buchse nicht alle leitungen mit dem kabel verbunden waren also nur 5 leitungen waren im kabel. also einfach mal alle pins des kabels mit nem durchgangsprüfer checken

    lg
    martin

  3. #3
    Hallo Martin,

    vielen Dank erst einmal für Deine Antwort.
    Richtig, man kann bei MotSTEP in den Einstellungen den zu verwendenden LPT-Port auswählen. Allerdings habe ich bereits darauf geachtet und definitiv den Richtigen ausgewählt. Den Fehler kann ich damit also ausschließen.

    Bei mir sind die benötigten Ausgänge des LPT auf jeden Fall belegt. Ich habe ja schon geschrieben, dass alle für die Platine relevanten Ausgänge dauerhaft Spannung (=5V) führen. Das ist ja anscheinend der Fehler.

    Kannst Du mir ne Software empfehlen, bei der ich die Pins des LPT ansteuern kann? Dann würde ich damit mal versuchen, ob überhaupt eine Statusänderung bei den Pins möglich ist.

    Gruß

  4. #4
    Erfahrener Benutzer Begeisterter Techniker Avatar von RobbyMartin
    Registriert seit
    31.12.2009
    Ort
    Leverkusen
    Alter
    24
    Beiträge
    206
    http://www.point2click.de/freeware/parswitch.html

    das ist zB ein programm

    lg
    martin

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •