-
        

Ergebnis 1 bis 5 von 5

Thema: Probleme mit Takt des 16F628A

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    24.12.2006
    Beiträge
    21

    Probleme mit Takt des 16F628A

    Anzeige

    ich habe mir einen PIC-Brenner selbst gebaut.

    Das brennen funktioniert auch so weit.

    Auf der gleichen Platine habe ich 4 Taster und 6 LEDs für Testzwecke integriert.

    für den Takt habe ich einen 20 MHz Qaurz und 2 15pF Kondensatoren angeschlossen.

    diese schalte ich über einen "Jumper-Schalter" auf die 2 Pins des PIC.

    Wenn ich die Spannung nun einschalte geht der PIC nicht.
    Scheinbar bekommt er keinen Takt.
    wenn ich dann etwas an den Jumperschalter rumspiele funktioniert der PIC irgendwann. --> Eingangssignale werden eingelesen Ausgänge ausgegeben. Bei erneutem Spannungseinschalten funktioniert der PIC wieder nicht.

    Mir kommt das vor, wie wenn er nicht von alleine "anschwingt".

    im CONFIG steht er auf HS.


    wie kann das sein?

    PS.: Ich habe schon die Kondesatoren mit etwas dickeren Leitungen auf Masse gezogen...

    kein Erfolg

  2. #2
    Erfahrener Benutzer Lebende Robotik Legende Avatar von PICture
    Registriert seit
    10.10.2005
    Ort
    Freyung bei Passau in Bayern
    Alter
    66
    Beiträge
    10.970
    Hallo katze117!

    Ich kenne deine Platine nicht, aber bei meiner selbstgebauten waren die Montagekapazitäten an Quarzanschlüssen schon um 30 pF und sie läuft wunderbar ohne "normallen" Kondensatoren. Bei selbstgebauten Platinen ist die Inbetriebnahme leider meistens länger als bei feriggekauften...

    Es könnte auch sein, das der Quarz zu niedrige Güte hat, probier mal, bitte, mit verschiedenen.

    MfG

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    08.06.2010
    Beiträge
    26
    Ist doch wohl offensichtlich woran das liegt, an Deinem komischen Jumper.

    Ist doch schon eine Schnapsidee den Quarz über Jumper mit dem PIC zu verbinden.

    Wahrscheinlich hast Du noch ein 20m Verlängerunskabel dran.

  4. #4
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    30.09.2006
    Ort
    Hamburg
    Alter
    35
    Beiträge
    988
    @ Biosniper das kann schon funktionieren wehre nicht der erste der das macht nur das 15pF etwas wenig sind um 22p würde ich vorschlagen.
    Legastheniker on Bord !

    http://www.Grautier.com - Projektseite
    http://www.grautier.com/wiki/doku.php?id=bt-index - BT-BUS

  5. #5
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    06.01.2009
    Alter
    26
    Beiträge
    104
    Die Jumper brauchst du doch gar nicht. Du musst zum Brennen den Takt vom PIC nicht weg nehmen (ansonsten würde auch ICSP nicht funktionieren).

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •