Hallo Leute

Ich habe mir bei ebay ein GLCD-touchscreen gekauft und habe diesen an einen Atmega128 angeschlossen. Hier der Link zum GLCD :http://cgi.ebay.de/LCD-TFT-240320-CO...item3efdaddfaf

Den GLCD habe ich über SPI angeschlossen, wobei ich aus Unachtsamkeit die Pins 1-20 vom GLCD verkehrt herum angeschlossen hab, sprich 5V an Pin 20 anstatt an Pin 1 etc (Pinbelegung siehe ebay-link). Bei dem Artikel waren auch Demoprogramme dabei, dich ich ausprobieren wollte. Das Flashen hatte anfangs nicht geklappt, bis ich bemerkt habe, dass ich die Pins vom GLCD falsch angeschlossen hab. Nach dem ich das alles korrigert habe, kappte das flashen auch ohne Probleme und das Programm läuft. Jedoch leuchtet beim GLCD lediglich nur die Hintergrundbeleuchtung. Es erscheint kein Schriftzug auf dem GLCD, der eigentlich hätte erscheinen müssen. Das Touchpenal funktioniert hingegen einwandfrei. Habe nun schon alles ausprobiert was mir eingefallen ist. Pinbelegung überprüft, Spannung gemessen, und über die 8 bit-schnittstelle angeschlossen, doch da geschieht auch nur genau das selbe. Hintergrundbeleuchtung kann ich ein und ausschalten, hintergrundfarbe oder ähnliches kann ich jedoch nicht verändern, bzw es passiert nix. Nun stellt sich mir die Frage ob ich den GLCD nun gegrillt hab oder ob ich irgendwas noch einstellen muss. Der Atmega128 läuft mit einem 16 Mhz Resonator und die Fusebits sind auch richtig eingestellt.

würd mich freuen wenn mir jemand weiterhelfen könnte

wünsch euch allen schonmal frohe Ostern