-         

Ergebnis 1 bis 3 von 3

Thema: mµAVR + Bascom-Einstellungen Hilfe

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    15.05.2006
    Beiträge
    14

    mµAVR + Bascom-Einstellungen Hilfe

    Anzeige

    Hallo Forum,

    habe ein Problem mit dem mk3 von mµAVR und Bascom.

    Habe den neusten Treiber installiert, Com5 zeigt Windows an.

    Habe unter Bascom (neueste Version 1.11.9.8 ) schon einige
    Prommereinstellungen probiert, komme aber nicht weiter.
    Die Hotline von mµAVR hat mir auch zu allgemeine Tipps gegeben.

    Weil ich schon gelesen habe, das die "Stk500 native"-
    Prommereinstellungen funktionieren sollen, habe ich es auch mit dieser
    probiert, aber ohne Erfolg.

    Im Anhang Bilder der Prommereinstellungen und die Fehlermeldung von
    Bascom.



    Wer kann mir da weiterhelfen??????

    Die Schaltung, die programmiert werden soll, ist ohne Quarz und hängt
    direkt am mµAVR. Dort soll nur eine LED blinken.
    Fusebits habe ich natürlich auch noch nicht setzen können!! Kann ich die
    eigentlich dann auch mit Bascom setzen??? Im Moment geht das natürlich
    nicht, da der Chip ja gar nicht erkannt wird!!!!!


    Hier noch das Programm:

    $regfile = "ATtiny13.dat"
    $crystal = 9600000
    $hwstack = 0
    $swstack = 0
    $framesize = 0
    Config Portb.4 = Output
    Do
    Toggle Portb.4
    Waitms 500
    Loop
    End



    Danke im voraus.
    Miniaturansichten angehängter Grafiken Miniaturansichten angehängter Grafiken stk500.png   flashen.png  

  2. #2
    Neuer Benutzer Öfters hier
    Registriert seit
    15.05.2006
    Beiträge
    14
    Jupiehh,

    es geht.

    Habe noch mal mit der Hotline telefoniert.

    Die haben sich da noch mal reingekniet und jetzt geht es.

    Also:

    am Prommer muß der mµ-Modus aktiviert werden
    --
    Bascom:
    Optionen, Simulator:
    Comport auswählen,
    "use integrated Simulator" aus,
    "run Simulaor after compilation" - an
    unter "Programm" den Verweis zum Programm Progtools (downloaden bei
    mµAVR)

    Optionen,Programmer:
    Programmer: "USBprog Programmer / AVR ISP mkII"
    Comport auswählen,

    Wenn ein Programm unter Bascom geschrieben ist, "F7" für kompilieren,
    Bascom kompiliert und es öffnet sich das Progtool. Dort unter dem Reiter
    "brennen" "Flash brennen" den Haken setzen und den Pfad zu der hex-Datei
    von Bascom eingeben. Unten den Button "brennen" klicken - fertig.

    Hört sich alles wild an, aber das meiste sind nur Einmal-Einstellungen.
    Wenn die gemacht sind, hat man fix sein Programm drin. Die Übertragung
    ist eigentlich auch schnell.

    Viel Spaß noch allen mit dem mk3!!!

    nero24

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    15.05.2006
    Beiträge
    14
    Jupiehh,

    es geht.

    Habe noch mal mit der Hotline telefoniert.

    Die haben sich da noch mal reingekniet und jetzt geht es.

    Also:

    am Prommer muß der mµ-Modus aktiviert werden
    --
    Bascom:
    Optionen, Simulator:
    Comport auswählen,
    "use integrated Simulator" aus,
    "run Simulaor after compilation" - an
    unter "Programm" den Verweis zum Programm Progtools (downloaden bei
    mµAVR)

    Optionen,Programmer:
    Programmer: "USBprog Programmer / AVR ISP mkII"
    Comport auswählen,

    Wenn ein Programm unter Bascom geschrieben ist, "F7" für kompilieren,
    Bascom kompiliert und es öffnet sich das Progtool. Dort unter dem Reiter
    "brennen" "Flash brennen" den Haken setzen und den Pfad zu der hex-Datei
    von Bascom eingeben. Unten den Button "brennen" klicken - fertig.

    Hört sich alles wild an, aber das meiste sind nur Einmal-Einstellungen.
    Wenn die gemacht sind, hat man fix sein Programm drin. Die Übertragung
    ist eigentlich auch schnell.

    Viel Spaß noch allen mit dem mk3!!!
    nero24

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •