-         

Ergebnis 1 bis 7 von 7

Thema: Wer kann helfen bei fehlersuche in schrittmotorsteuerung?

  1. #1

    Wer kann helfen bei fehlersuche in schrittmotorsteuerung?

    Anzeige

    Hihi

    Ich habe folgende Situation:

    Seit meiner ersten CNC-Fräse im Eigenbau komme ich von diesem Bereich der Freizeitlichen Beschäftigung nicht mehr los. Es ist so, dass ich mir nun eine neue Fräse baue, die Steuerung ist schon im Bau, aber irgendwie will diese Steuerung nicht wie ich will. Sie ist mit einem l297 und zwei l6203 aufgebaut, damit ich zu möglichst vielen Programmen kompatibel bin. Ich habe mir die Platine auf meiner anderen Fräse selbst gefräst und dann zusammengelötet. Allerdings will die Steuerung nicht wie ich will. Isoliert sind alle Leiterbahnen und kalte Lötstellen gibt es auch keine, sowie die Bauteile, die sind alle meines wissens nach richtig drin.

    Die syntome sind:
    - ständiges stottern des Schrittmotors (Als ob der l297 immer leichte taktsignele bekommt)
    - Wenig Haltekraft
    - Motor wird extrem schnell extrem heiß
    - beim verfahren über EMC² seeeehr sehr viele schrittfehler

    Ich hänge mal die Schltung und den Plan des Boardes hinten dran, villeicht findet jemand einen Fehler, weil ich bin nach 2 Tagen Fehlersuche am Ende.

    http://www.imagebanana.com/view/e72n5398/platine.JPG

    http://www.imagebanana.com/view/qwoaq5js/schaltung.JPG

    Danke

    MfG
    Michi
    Meine eigene cnc-Fräse:
    mihuno.oyla3.de

  2. #2
    Erfahrener Benutzer Robotik Visionär
    Registriert seit
    26.11.2005
    Ort
    bei Uelzen (Niedersachsen)
    Beiträge
    7.942
    Das Platinenlayout sieht gar nicht gut aus. Da werden Leiterbahnen für den Motorstrom und gleichzeitig für Steuerleitungen genutzt. Da sind Störungen zu erwarten. Auch ist der Abblockkondensator für den L297 sehr weit weg vom Chip. Wenigstens das kann man aber beheben mit eine zusätzlichen Kondensator etwa zwischen dem Spannungsregler und dem L297. Platz ist da ja genug.

    Ähnlich schlecht sieht es mit C5, C6 aus. Auch die gehöhren dicht ans IC. Man kann die alten drin lassen, und dann zusätzliche Kondensatoren dicht am IC anbringen. Wenn sein muß von unten unter die Platine. Platz wäre da ja sogar auch gewesen, jeweils rechts vom IC.


    Stimmt den der Wert von C2, und damit die Taktfrequenz beim L297 ? Die Bauform für 3.3 nF kommt mir etwas groß vor. Die Lage im Layout ist auch zu ziehmlich der schlechteste Punkt, den man für Masse finden kann.

    Die Leitung vom Poti zum Vref pin geht auch quer über die platine, um möglichst viele Störungen einzufangen. Hier könnte man was ressen mit einem Kondensator gegen GND, z.B. bei den beiden großem Shunts. Damit sollte die Spannung an den Shunt und Vref ähnliche Störungen bekommen - die Differenz sollte sich dann hoffentlich rausheben.

    Ein erster Test für den Eingangsteil wäre es mal von der Steuerung kein Signal Auszugeben und dann die Spannung an einem der Ausgänge A,B,C oder D über einige Zeit zu beobachten - da sollte man ungeplante Schritte erkennen.

  3. #3
    Erfahrener Benutzer Robotik Visionär Avatar von Hubert.G
    Registriert seit
    14.10.2006
    Ort
    Pasching OÖ
    Beiträge
    6.186
    Die Kondensatoren unmittelbar vor und nach dem Spannungsregler fehlen auch.
    Grüsse Hubert
    ____________

    Meine Projekte findet ihr auf schorsch.at

  4. #4
    hey

    Ja also der Schrittmotor stottert auch ohne eingangssignal. Das heißt ich muss die ganze platine am besten nochmal neu aufbauen oder?

    Edit: Ich hab hier was gefunden, die schaltung sieht gut aus, aber soweit ich das Bewerten kann kann ich hier blos 5V auf den eingang geben, liege ich da richtig?
    http://i23.tinypic.com/28lg9c8.png

    MfG
    Michi
    Meine eigene cnc-Fräse:
    mihuno.oyla3.de

  5. #5
    Erfahrener Benutzer Robotik Visionär Avatar von Hubert.G
    Registriert seit
    14.10.2006
    Ort
    Pasching OÖ
    Beiträge
    6.186
    Ich würde erst mal die Kondensatoren ergänzen und zusätzlich plazieren.
    Hier bietet sich die Verwendung von SMD-Kondensatoren an.
    Grüsse Hubert
    ____________

    Meine Projekte findet ihr auf schorsch.at

  6. #6
    Hey,

    Oke dann machich das mal. werde euch im laufe des tages sagen, obs was gebracht hat

    MfG
    Michi
    Meine eigene cnc-Fräse:
    mihuno.oyla3.de

  7. #7
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    19.02.2007
    Beiträge
    210
    wenn du dir als HOBBY CNC-ler noch etwas gutes tun willst kannst du die fertigen platinen für 20euro zb von mechapro verwenden und sie mit deinen bereits vorhandenen teilen bestücken dann läuft das auch sauber !
    bei mir hat der eigenbau auch so seine tücken.
    mit der nun 5ten Fräse und die 4te mit der platine von dem anbieter gab es noch nie probleme!

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •