-         

Ergebnis 1 bis 5 von 5

Thema: PC-Anschluss an RS232-Schnittstelle gelingt nicht.

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    15.02.2010
    Ort
    Raum Kassel
    Beiträge
    10

    PC-Anschluss an RS232-Schnittstelle gelingt nicht.

    Anzeige

    Hallo.

    Ich habe eine echte RS232-Schnittstelle an meinem PC und erfolglos versucht mich über minicom zu verbinden. Über minicom -s habe ich ttyS0 probiert, sowie alle Möglichkeiten was Hardware/Software-Flowcontrol angeht. Das Ergebnis ist immer das gleiche: Es kommt kein Eingabeprompt, ich muss das Terminal killen. Minicom reagiert auf nichts.

    Außerdem habe ich Cutecom probiert. Außer einigen wenigen Hexcodes ist nichts zu sehen. Wenn ich die Schnittstelle entferne seh ich zumindest schon mal, dass der Hexcode nicht erscheint. Was darauf hindeutet, das damit interagiert wird. Die Hexwerte gehen bis 255 und in Latin-1 konvertiert ergeben sie nur wirres Zeug.

    Außerdem habe ich festgestellt, dass der Rechner mit angeschl. Schnittstelle nicht hochfährt, weil er ein xyz MHz Gerät nicht kennt.

    Habt ihr Ideen wie ich weiter vorgehen kann. Mir fällt nur ein eine USB-Schnittstelle oder ein Multimeter zu kaufen, womit ich mich aber auch nicht auskenne... . Die Lötstellen sehen ok aus. Auf eine Fernbedienung reagiert das Gerät nicht, und auch sonst nie.

    Arbeite mit Kubuntu 9.10

    VG
    _pingu

  2. #2
    Neuer Benutzer Öfters hier
    Registriert seit
    15.02.2010
    Ort
    Raum Kassel
    Beiträge
    10
    Korrektur:
    Minicom hängt sich nicht auf. Ich kann es normal verlassen.

    Muss ich sowohl bei Hard- als auch bei Software Flowcontrol ein Nein auswählen?

    Welchen Befehl muss ich eingeben um eine Verbindung herzustellen? Was sollte dann angezeigt werden?

    Nachtrag:
    GtkTerm verbindet sich auch nicht.

  3. #3
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    01.02.2010
    Ort
    irgendwo in BW
    Beiträge
    154
    hallo _pingu,
    ohne zu wissen was für eine rs232-Schnittstelle du hast, kann man gar nichts sagen(hast du den ir adapter vom asuro?) und hast du genau die com-port einstellungen, die auch in der anleitung beschrieben sind?
    mir fällt gerade auch nicht ein woran es sonst liegen könnte.
    gruß josua

  4. #4
    Neuer Benutzer Öfters hier
    Registriert seit
    15.02.2010
    Ort
    Raum Kassel
    Beiträge
    10
    Hi josua,

    ich hab die Schnittstelle die bei Asuro dabei ist. Einstellungen hab ich aus dem Manual bereits mit 3 Programmen getestet. Hab mir mittlerweile die USB-Schnittstelle bestellt. Da ich trotzdem wissen will woran es liegt auch ein Multimeter.

    VG
    _pingu

  5. #5
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    01.03.2008
    Ort
    Niederlanden
    Beiträge
    1.167
    Ich bin gar keine Linux guru. Letztes jahr habe ich ein wenig mit Asuro und OpenSuse rumgespielt. Dabei musste ich ein gewissen comando ausfuhren damit mein user auch lies- und schreibrechten bekam auf die serielle schnitstelle. Etwas mit chmod 666. Zum Teufel! Was war das genau?

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •