-         

Seite 1 von 3 123 LetzteLetzte
Ergebnis 1 bis 10 von 24

Thema: Wieder I2C TWI

  1. #1
    Erfahrener Benutzer Roboter Genie Avatar von oratus sum
    Registriert seit
    25.12.2006
    Ort
    Wien
    Alter
    26
    Beiträge
    1.079
    Blog-Einträge
    1

    Wieder I2C TWI

    Anzeige

    SMARTPHONES & TABLETS-bis zu 77% RABATT-Kostenlose Lieferung-Aktuell | Cool | Unentbehrlich
    Hallo,

    Ich versuche gerade aus den zwei Bsp Programmen im Wiki und den AVR Dokus ein m16 Slave zu programmieren.

    Mein Master ist ein RN2560 Modul Slave wie erwähnt ein Mega16

    Mein Master funktioniert einwandfrei. Ich habe aus dem Wiki die 2 Beispiele Transmitter und Reciever kombiniert- Dann habe ich die einzelnen bsps für den Slave hergenommen (einmal Recieve, einmal Transmit) - funktioniert.

    Wenn ich aber die 2 Beispiele für den Slave kombinieren, funktioniert das Auslesen der Bytes nicht.

    Hier mein Slave Code:
    Code:
    'Microcontroller
    '================
    $regfile = "m16def.dat"
    $crystal = 1000000
    $hwstack = 32
    $swstack = 10
    $framesize = 40
    
    Config Scl = Portc.0                                        'Ports fuer IIC-Bus
    Config Sda = Portc.1
    Config I2cdelay = 10
    
    Dim Twi_control As Byte                                     ' Controlregister lokale kopie
    Dim Twi_status As Byte
    Dim Twi_data As Byte
    
    Dim Neuesbyte As Byte                                       ' Bytemerker
    
    Declare Sub Twi_init_slave
    
    Twi_data = 0
    Call Twi_init_slave                                         ' TWI aktivieren
    
    ' alle LEDs ein
    Portb = 0
    
    ' Hauptschleife
    Do
        ' hier könnte ihr Code stehen
    Portb = 0
    
        ' Merker zurücksetzen
        Neuesbyte = 0
    
        ' schauen ob TWINT gesetzt ist
        Twi_control = Twcr And &H80                             ' Bit7 von Controlregister
    
        If Twi_control = &H80 Then
            Twi_status = Twsr And &HF8                          ' Status
    
            ' wurde ein Byte geschickt
            If Twi_status = &H80 Or Twi_status = &H88 Then
                Twi_data = Twdr                                 ' neue Daten merken
                Neuesbyte = 1                                   ' merken das ein neues Byte da ist
            End If
    
            ' will der Master ein Byte haben
            If Twi_status = &HA8 Or Twi_status = &HB8 Then
                Twdr = 245                                      ' neue Daten ausgeben
            End If
    
            ' TWINT muss immer gelöscht werden, damit es auf dem Bus weiter geht
            Twcr = &B11000100                                   ' TWINT löschen, erzeugt ACK
        End If
    
        ' wenn ein neues Byte gekommen ist, dieses an PortD ausgeben
        If Neuesbyte <> 0 Then
            Portb = 1
        Wait 1                                                  ' Daten auf PortD ausgeben
        End If
    Loop
    
    End
    
    
    ' Unterprogramme
    
    
    ' TWI als slave aktivieren
    Sub Twi_init_slave
        Twsr = 0                                                ' status und Prescaler auf 0
        Twdr = &HFF                                             ' default
        Twar = &H20                                             ' Slaveadresse setzen
        Twcr = &B01000100                                       ' TWI aktivieren, ACK einschalten
    End Sub
    Master:
    Code:
    '===============================================================================
    '=========================Beginn der Initialisierung============================
    '===============================================================================
    '\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\
    '============================== Deklaration ====================================
    '$sim
    $prog , 255 , &B11011001 ,                                  'Quarz an / Teiler aus / Jtag aus
    $regfile = "m2560def.dat"                                   'Definitionsfile für M2560 Prozessor
    $hwstack = 82                                               '80 Hardwarestack
    $framesize = 68                                             '64 Framesize
    $swstack = 68                                               '44 Softwarestack
    $baud = 19200                                               'Baudrate für UART
    $crystal = 16000000                                         'Quarzfrequenz
    
    '================================ Port Konfiguration ===========================
    
    Config Pind.5 = Output
    Config Portc = Output
    
    
    Config Scl = Portd.0                                        'Ports fuer IIC-Bus
    Config Sda = Portd.1
    Config I2cdelay = 10
    
    Config Com3 = 19200 , Synchrone = 0 , Parity = None , Stopbits = 1 , Databits = 8 , Clockpol = 0
    Config Serialin3 = Buffered , Size = 100
    Config Serialout3 = Buffered , Size = 1
    
    
    Led_go Alias Portd.5                                        'Status LED am Controller
    Led_stat Alias Portb.0
    
    Const Mars_firmware = "0.0.1"
    Const Mars_filename = "Master_trancieve.bas"
    Const Mars_filedate = "21.02.2010"
    
    Declare Sub Twi_send_byte(byval Slave As Byte , Zeichen As Byte)
    Declare Function Twi_read_byte(byval Slave As Byte) As Byte
    
    Dim Twi_control As Byte                                     ' Controlregister lokale kopie
    Dim Twi_status As Byte
    Dim Twi_data As Byte
    
    Dim B As Byte                                               ' Zeichen von UART
    Dim X As Byte                                               ' Zeichen von TWI
    Dim Error As Byte                                           ' Fehlermerker
    
    ' TWI Init
    Twcr = &B00000100                                           ' erstmal nur TWI aktivieren
    Twsr = 0                                                    ' Status und Prescaler Register
    Twbr = 72
    '======================INIT===============================
    
    '======================INIT===============================
    Init:
    
    
    
       Led_go = 0
       Led_stat = 1
       'Open  UART
       Open "COM3:" For Binary As #3
       Print #3 , "============="
       Print #3 , Mars_firmware
       Print #3 , Mars_filename
       Print #3 , Mars_filedate
       Print #3 , "============="
    
    '========================================================
    
    '=====================MAIN LOOP=========================
    Main:
    Wait 1
    
    B = 2
    X = Twi_read_byte(&H20)
    If X = 245 Then Toggle Led_go
    Call Twi_send_byte(&H20 , B)
    
    Print #3 , X
    Goto Main
    ' Unterprogramme
    Sub Twi_send_byte(byval Slave As Byte , Zeichen As Byte)
        Error = 0                                               ' Fehler zurücksetzen
    
        ' Startbedingung
        Twcr = &B10100100                                       ' TWINT
    
        ' warten bis TWINT gesetzt ist
        Gosub Twi_wait_int
    
        ' wenn Zugriff auf den Bus erlaubt, Slaveadresse ausgeben
        If Twi_status = &H08 Or Twi_status = &H10 Then
            Twdr = Slave And &HFE                               ' slave adresse + Write
            Twcr = &B10000100                                   ' TWINT löschen, Byte senden
    
            ' warten bis TWINT gesetzt ist
            Gosub Twi_wait_int
    
            ' Slave hat sich gemeldet
            If Twi_status = &H18 Or Twi_status = &H20 Then
                Twdr = Zeichen                                  ' Daten
                Twcr = &B10000100                               ' TWINT löschen, Byte senden
    
                ' warten bis TWINT gesetzt ist
                Gosub Twi_wait_int
    
                ' Zeichen wurden gesendet
                If Twi_status = &H28 Or Twi_status = &H30 Then
                    Error = 0                                   ' kein Fehler
                Else
                    Error = Twi_status                          ' Fehler
                End If
    
            Else
                ' kein slave
                Error = Twi_status                              ' Fehler
            End If
    
            ' STOPbedingung kommt hier immer im Ablauf, egal welcher Status
            Twcr = &B10010100                                   ' TWINT löschen, STOP senden
            ' nach einem STOP wird TWINT nicht mehr gesetzt,
            ' man darf/kann also nicht darauf warten !
    
        Else
            ' Bus belegt, wird er wieder freigegeben
            Twcr = &B10000100                                   ' TWINT löschen, Bus freigeben
            Error = Twi_status                                  ' Fehler
        End If
    
    End Sub
    
    ' TWI read_byte
    ' holt ein Byte und schliesst die Übertragung ab
    Function Twi_read_byte(slave As Byte) As Byte
        Error = 0                                               ' Fehler zurücksetzen
    
        Twi_read_byte = 0                                       ' Wert vorbelegen
    
        ' Startbedingung
        Twcr = &B10100100                                       ' TWINT
    
        ' warten bis TWINT gesetzt ist
        Gosub Twi_wait_int
    
        ' wenn Zugriff auf den Bus erlaubt, Slaveadresse ausgeben
        If Twi_status = &H08 Or Twi_status = &H10 Then
            Twdr = Slave Or &H01                                ' slave adresse + Read
            Twcr = &B10000100                                   ' TWINT löschen, Byte senden
    
            ' warten bis TWINT gesetzt ist
            Gosub Twi_wait_int
    
            ' Slave hat sich gemeldet
            If Twi_status = &H40 Then
                Twcr = &B10000100                               ' TWINT löschen, Byte senden
                              ' kein ACK (TWEA = 0) senden, weil wir nur ein Byte lesen wollen
    
                ' warten bis TWINT gesetzt ist
                Gosub Twi_wait_int
    
                ' ein Byte wurde empfangen
                If Twi_status = &H58 Or Twi_status = &H50 Then
                    Twi_read_byte = Twdr                        ' Daten lesen
                    Error = 0                                   ' kein Fehler
                Else
                    Error = Twi_status                          ' Fehler
                End If
    
            Else
                ' kein slave
                Error = Twi_status                              ' Fehler
            End If
    
            ' STOPbedingung kommt hier immer im Ablauf, egal welcher Status
            Twcr = &B10010100                                   ' TWINT löschen, STOP senden
            ' nach einem STOP wird TWINT nicht mehr gesetzt,
            ' man darf/kann also nicht darauf warten !
    
        Else
            ' Bus belegt, wird er wieder freigegeben
            Twcr = &B10000100                                   ' TWINT löschen, Bus freigeben
            Error = Twi_status                                  ' Fehler
        End If
    
    End Function
    
    ' warten bis TWINT gesetzt ist, status auslesen
    Twi_wait_int:
        Do
            Twi_control = Twcr And &H80
        Loop Until Twi_control = &H80
    
        Twi_status = Twsr And &HF8                              ' status
        ' status nur zu Debugzwecken ausgeben, weil Bus sehr langsam wird !
    '    Print "Err " ; Hex(twi_status)
    Return
    Slave hat die Adresse &H20


    Und jetzt eine generelle Frage:
    was ist der Unterschied zwischen TWI und I2C?

    Wenn im Slave das Programm aus dem Wiki für "auf Abruf Senden " läuft dann kann ich per TWI im Master das Byte auslesen, benutze ich jedoch die standart I2C Befehle:

    I2Cstart
    I2Cwbyte &H20
    I2Crbyte X
    I2Cstop

    funktioniert es nicht, wieso?

  2. #2
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    22.05.2005
    Ort
    12°29´ O, 48°38´ N
    Alter
    48
    Beiträge
    2.731
    Hi,

    Wie im Wiki bei TWI zu lesen, ist es das selbe wie I2C.

    Wo schreibst Du diese zuletzt genannten I2C-Befehle hin (Master/Slave) ?
    Diese Befehle kann man nur beim Master benutzen !

    PS:
    Eine Sekunde Wartezeit beim Slave ist fast etwas lang, um damit etwas gescheites zu Testen !

  3. #3
    Erfahrener Benutzer Roboter Genie Avatar von oratus sum
    Registriert seit
    25.12.2006
    Ort
    Wien
    Alter
    26
    Beiträge
    1.079
    Blog-Einträge
    1
    Ja aber die eine Sekunde hat funktioniert. Es hat natürlich ein wenig komisch reagiert, aber das war ja zu erwarten. Es schaltet auf jeden Fall auf High/Low halt nicht regelmäßig aber zum. weiss ich , dass er die Daten erhält.

    Natürlich werden die I2C Befehle vom Master gesendet.

    Okay ist das gleiche...

    Was sagst du zum Code? Das müsste doch funktionieren. Ich sitz schon fast den ganzen tag dran...

  4. #4
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    22.05.2005
    Ort
    12°29´ O, 48°38´ N
    Alter
    48
    Beiträge
    2.731
    Mit den Bascom-I2C-Befehlen muss das auch gehen.
    Das einzige was mit jetzt auffällt, wäre die SlaveAdresse bei Deinem Beispiel,
    beim lesen vom Slave muss diese +1 zur Schreibadresse sein, also hier &H21 !

    PS:
    Zum debuggen kannst Du nach jedem I2C-Befehl ein Print TWSR einbauen, um zu sehen wie's dem TWI-Modul geht.

  5. #5
    Erfahrener Benutzer Roboter Genie Avatar von oratus sum
    Registriert seit
    25.12.2006
    Ort
    Wien
    Alter
    26
    Beiträge
    1.079
    Blog-Einträge
    1
    da wäre doch diese Zeile oder?

    Twdr = Slave And &HFE ' slave adresse + Write

  6. #6
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    22.05.2005
    Ort
    12°29´ O, 48°38´ N
    Alter
    48
    Beiträge
    2.731
    Ja für write muss das erst Bit gelöscht sein, was mit dem AND geschieht, beim lesen muss es gesetzt sein, da muss irgendwo ein OR &H01 sein.

  7. #7
    Erfahrener Benutzer Roboter Genie Avatar von Bammel
    Registriert seit
    11.12.2004
    Ort
    Bremen
    Alter
    30
    Beiträge
    1.400
    Hallo,

    schau dir mal unter stehenden code an. diesen verwende ich bei mir und der läuft ganz gut.

    Code:
    '*******************************************************************************
    '  um mit dem master zu senden folgenden code benutzen
    '
    '  I2cstart
    '  i2cwbyte &H22    'slave-id
    '  I2cwbyte 1       'für motor 1
    '  I2cwbyte PWM1
    '  I2cwbyte PWM1b   'falls die pwm variable größer als ein byte ist
    '  I2cstop
    '
    '*******************************************************************************
    
    '===============================================================================
    '***| Mikrocontroller Config |**************************************************
    '===============================================================================
    
    'Microcontroller
    '================
    $regfile = "m8def.dat"
    $crystal = 16000000
    $hwstack = 32
    $swstack = 10
    $framesize = 40
    
    
    'TWI
    '====
    Declare Sub Twi_init_slave
    Dim Twi_control As Byte
    Dim Twi_status As Byte
    Dim Command As Byte
    Dim Index As Byte
    Dim Newbyte As Byte
    Dim I2cbyte(10) As Byte
    Dim N As Byte
    
    Enable Interrupts
    
    
    'Init
    '=====
    For N = 1 To 10
       I2cbyte(n) = 0
    Next N
    
    Command = 0
    Index = 0
    
    Call Twi_init_slave
    
    '-------------------------------------------------------------------------------
    '***| Hauptprogramm |***********************************************************
    '-------------------------------------------------------------------------------
    Do
         Newbyte = 0
    
         'schauen ob TWINT gesetzt ist
         Twi_control = Twcr And &H80                            ' Bit7 von Controlregister
    
         If Twi_control = &H80 Then
            Twi_status = Twsr And &HF8                          ' Status
    
            'wurde ein Byte geschickt?
            If Twi_status = &H80 Or Twi_status = &H88 Then
                Command = Twdr                                  ' neue Daten merken
                Newbyte = 1                                     ' merken das ein neues Byte da ist
            End If
    
    
            'TWINT muss immer gelöscht werden, damit es auf dem Bus weiter geht
            Twcr = &B11000100                                   ' TWINT löschen, erzeugt ACK
         End If
    
         'wenn ein neues Byte gekommen ist verarbeiten
         If Newbyte <> 0 Then
    
           'Register zuordnen -> Befehl
           Select Case Command
    
                   Case 1
                   Gosub Motor1
    
                   Case 2
                   Gosub Motor2
    
                   Case 3
                   Gosub Motor3
    
    
           End Select
    
    
         End If
    
    Loop
    End
    
    
    
    
    '-------------------------------------------------------------------------------
    '***| Motor 1 |*****************************************************************
    '-------------------------------------------------------------------------------
    Motor1:
    
       Index = 1
       '1 Byte holen / gibt an wieviele bytes geholt werden sollen hier im beispiel max. 10 "i2cbyte(1 bis 10)"
       Gosub I2c_rx
    
       'PWM1 = i2cbyte(1)
    
    Return
    
    
    '-------------------------------------------------------------------------------
    '***| Motor 2 |*****************************************************************
    '-------------------------------------------------------------------------------
    Motor2:
    
       Index = 1                                                '1 Byte holen
       Gosub I2c_rx
    
       'PWM2 = i2cbyte(1)
    
    Return
    
    
    '-------------------------------------------------------------------------------
    '***| Motor 3 |*****************************************************************
    '-------------------------------------------------------------------------------
    Motor3:
    
       Index = 1                                                '1 Byte holen
       Gosub I2c_rx
    
       'PWM3 = i2cbyte(1)
    
    Return
    
    
    
    '-------------------------------------------------------------------------------
    '***| I2C-BUS Daten Empfangsroutinen |******************************************
    '-------------------------------------------------------------------------------
    I2c_rx:
    
     For N = 1 To Index
     'erstes Byte empfangen
     Newbyte = 0
     Do
    
        Twi_control = Twcr And &H80
    
        If Twi_control = &H80 Then
            Twi_status = Twsr And &HF8
    
            If Twi_status = &H80 Or Twi_status = &H88 Then
                I2cbyte(n) = Twdr
                Newbyte = 2
            End If
    
            Twcr = &B11000100
        End If
    
        If Newbyte = 2 Then Exit Do
    
     Loop
    
     Next N
    
    Return
    
    '-------------------------------------------------------------------------------
    '***| I2C-BUS Daten Senderoutinen |******************************************
    '-------------------------------------------------------------------------------
    I2c_tx:
    
    For N = 1 To Index
     'erstes Byte empfangen
     Newbyte = 0
     Do
    
        Twi_control = Twcr And &H80
    
        If Twi_control = &H80 Then
            Twi_status = Twsr And &HF8
    
            If Twi_status = &HA8 Or Twi_status = &HB8 Then
                Twdr = I2cbyte(n)
                Newbyte = 2
            End If
    
            Twcr = &B11000100
        End If
    
        If Newbyte = 2 Then Exit Do
    
     Loop
    
    Next N
    
    Return
    
    '-------------------------------------------------------------------------------
    '***| TWI: Slavekonfiguration |*************************************************
    '-------------------------------------------------------------------------------
    
    Sub Twi_init_slave
        Twsr = 0                                                ' status und Prescaler auf 0
        Twdr = &HFF                                             ' default
        Twar = &H22                                             ' Slaveadresse setzen  I2C-RX-Adr:Hex22
        Twcr = &B01000100                                       ' TWI aktivieren, ACK einschalten
    End Sub
    Gruß,
    Bammel

  8. #8
    Erfahrener Benutzer Roboter Genie Avatar von oratus sum
    Registriert seit
    25.12.2006
    Ort
    Wien
    Alter
    26
    Beiträge
    1.079
    Blog-Einträge
    1
    Ich werde versuchen mal den Master auf die standart I2C Befehle um zu setzen, sollte ja funktionieren.

    @Bammel
    Vom Prinzip ist es ja genauso, ist ja alles vom RN Wiki bzw Ulli Sommer Buch

    Ich vertiefe mich grad sehr im Detail in die Materie... mal sehen ob ich dann waas finden kann...

  9. #9
    Erfahrener Benutzer Roboter Genie Avatar von Bammel
    Registriert seit
    11.12.2004
    Ort
    Bremen
    Alter
    30
    Beiträge
    1.400
    den code habe ich von herrn ulli sommer per mein geschickt bekommen... naja so in der art ich habs dann nur in eine for next schleife gesetzt

  10. #10
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    19.03.2006
    Beiträge
    244
    hey könnt ihr mir vielleicht ein wenig auf die Sprünge helfen? Ich hab mich jetzt auch schon ne ganze Weile damit beschäftigt. Ich hab den Code jetzt mal für Versuchszwecke 1:1 übernommen. Das Senden zum Slave funktioniert auch einwandfrei. Wenn ich jetzt aber was zurückschicken will also Slave Trans. bzw Masterrec., dann geht das irgendwie nicht.

    liege ich richtig wenn ich in jetzt ein Byte übertragen möchte dieses zunächst in i2cbyte(1) z.b. schreibe und dann die i2c_tx aufrufe oder?

    Am Master hab ich folgendendes geschrieben:
    Code:
    i2cstart
    i2cwbyte &h22  
    i2cwbyte 1 ' signal für den slave ein byte zu schicken
    i2crbyte var, nack
    i2cstop
    oder muss ich da zwischen durch den Salve mit &h23 als Adresse initialisieren oder sowas? wär echt gut wenn ihr mir helfen könnt, bin nämlich leicht unter Zeitdruck, ist für ein schulisches Projekt.

    grüße Jo

Seite 1 von 3 123 LetzteLetzte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •