-         

Ergebnis 1 bis 5 von 5

Thema: NIBObee: Verbesserung der Stromaufnahme

  1. #1
    Benutzer Stammmitglied
    Registriert seit
    12.01.2010
    Beiträge
    53

    NIBObee: Verbesserung der Stromaufnahme

    Anzeige

    Hallo zusammen,

    ich lese hier häufiger Probleme, dass die Akkus schnell leer sind und alle Regelungsvorgänge durch stark schwankende Spannungsversorgung beim Fahren vereitelt werden.

    Um letzteres in den Griff zu bekommen wäre ein Umbau der NIBObee-Logik auf eine geregelte 3 V Spannungsversorgung notwendig. Das erscheint mir recht aufwendig.

    Um die Akkus weniger schnell leer werden zu lassen, schlage ich einen Umbau der LED-Vorwiderstände auf 470 Ohm vor. Ich habe das bei meiner Biene schon bei allen sichtbaren LEDs gemacht und die leuchten so auch noch hell genug. Immerhin lassen sich so bis zu 60 mA Strom sparen.

    Experimentieren werde ich noch mit den beiden Odometrie-IR-LEDs. Da die beiden ständig an sind und die Fototransistoren direkt bestrahlen, sind da geringere Widerstände ebenfalls machbar. Des weiteren können diese beiden LEDs auch in Serie geschaltet werden, dadurch kann auch nochmal einiges gespart werden. Denn zur Zeit wird ja in beiden Vorwiderständen sinnlos Leistung verbraten...

    Für die Linienverfolgung werde ich den Widerstand nicht ändern. Durch die Reflektion ist das Signal an den Fototransitoren sehr viel schwächer als bei direkter Bestrahlung. Außerdem lassen sich diese ja ein- und ausschalten je nach Bedarf.

    In Software lässt sich auch noch ein Stromsparkonzept mit einem Idle-Modus und Sleep realisieren - so weit bin ich leider noch nicht

    Ciao bantyy

  2. #2
    Neuer Benutzer Öfters hier
    Registriert seit
    26.02.2010
    Ort
    Kreuzung BAB3 und B470
    Beiträge
    25
    Bin gerade beim Zusammenbauen:

    Also zur Stromaufnahme: bei mir schluckt ein Motor im Leerlauf (direkt angeschlossen) bei 4,5V schon 1,3A (Labornetzteil Anzeige).

    Das mit den Odometrie IRLed in Reihe könnte in der Praxis so funzen:

    Links den Widerstand R32 entfernen, von aussen in das Lötauge mit der dünnen Leiterbahn einen Draht rüber zur rechten Seite ziehen. Rechte Seite die Leiterbahn zwischen IRLed IR2 und Hauptplatine trennen, und von aussen den Draht an die Anode der IRLed anlöten.

    Leider hatte ich das Bestücken schon angefangen, bevor ich diesen Post las. Die 180 Ohm Widerstände wieder auslöten bringt's dann nicht wirklich; dann lieber die LEDs Programm gesteuert blinken oder blitzen lassen.

  3. #3
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    22.05.2007
    Ort
    Stolberg
    Beiträge
    111
    1,3A sind nicht gut! Das sollten die Motoren nicht einmal während der Fahrt ziehen...

  4. #4
    Neuer Benutzer Öfters hier
    Registriert seit
    26.02.2010
    Ort
    Kreuzung BAB3 und B470
    Beiträge
    25
    Mein Fehler:
    Ich dachte ich könnte die Motoren direkt von Labornetzteil einspeisen = aber beim Posten im Thread "NiboBee funktioniert nicht", habe ich dann gemerkt, dass das im Grunde genauso ist, wie Betrieb ohne das 74HC139. Einen Motor Pin abgelötet, jetzt sind's bei 4 Volt nur 0,09A.
    Möglicheise habe ich die H-Brücke gehimmelt..

  5. #5
    Benutzer Stammmitglied
    Registriert seit
    12.01.2010
    Beiträge
    53
    Hallo,

    Das mit den Odometrie IRLed in Reihe könnte in der Praxis so funzen:
    Und in der Praxis habe ich es genauso gemacht Allerdings habe ich noch nicht so genau geprüft, wie gut oder schlecht jetzt die Odometrie funktioniert. Dabei bin ich übrigens bei dem 180 Ohm Widerstand geblieben. Darüber fallen nun ca. 2,8 - 3,0 V ab, also fließen jetzt ca. 15 mA durch die beiden Dioden, vorher waren es 2 x 20 mA = 40 mA. Immerhin eine Absenkung um nochmal 25 mA. Nicht die Masse, aber alles zusammen macht das schon ein bißchen aus

    Ich schreibe eine eigene Library für die Biene und bin beruflich zur Zeit leider ziemlich eingespannt, deshalb werde ich dazu wohl noch etwas brauchen...

    Leider hatte ich das Bestücken schon angefangen, bevor ich diesen Post las. Die 180 Ohm Widerstände wieder auslöten bringt's dann nicht wirklich;
    Wieso denn das nicht? *wunder* Meine Biene ist schon seit dem 3. Januar zusammengelötet - die Widerstände hatte ich aber erst einen Monat später gewechselt. Man kann viel mit SW lösen, für den Stromverbrauch der LEDs will ich keine Rechenresourcen verballern... Zumal dafür ja keine aufwendigere Schaltung oder teure Bauteile nötig sind.

    Ciao bantyy

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •