-         

Ergebnis 1 bis 5 von 5

Thema: IR-Sensor

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    17.01.2009
    Ort
    ILLINGEN
    Alter
    59
    Beiträge
    21

    IR-Sensor

    Anzeige

    Hallo und frohes neues jahr,
    Ich habe da einen PIR - Sensor
    [img][/img]

    Nur komme ich nicht weiter.
    Habe versucht, mit dem Comparator
    2 Spannungen zu vergleichen. Die
    von einem Poti (bis 5Vregelbar) und
    halt die vom Sensor. Scheint aber nicht
    zu funktionieren.

    Code:
    $regfile = "m8def.dat"
    $crystal = 3686400
    Ddrd = &B00100000
    Acsr = &B00000000
    Do
      Portd.5 = Acsr.aco
    Loop
    End

    Wie kann man diesen mit Bascom
    noch ansteuern ?
    Muß ich da unbedingt über den
    A/D - Wandler gehen ? Bräuchte
    ja nur einen Interrupt auslösen, wenn
    5 V an einem bestimmten PIN ankommen.
    Miniaturansichten angehängter Grafiken Miniaturansichten angehängter Grafiken sensor_710.jpg  

  2. #2
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    15.01.2007
    Ort
    Göttingen
    Beiträge
    705
    Was für ein Signal gibt dieser PIR denn aus - analog oder digital?

    Falls es digital ist, kämst Du in der Tat ohne den Komparator aus; "Interrupt" wäre dann ein gutes Stichwort.

    An welche Pins hast Du denn das Signal und die Referenz vom Poti angelegt?

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    17.01.2009
    Ort
    ILLINGEN
    Alter
    59
    Beiträge
    21
    Laut mitgeliefertem Datenblatt steht :
    output signal : digital(hight)
    operation volatage : min 4.7 max : 12.0
    output voltage hight [V]: 5.0
    output duration[Sec] : 0.5

    hab das myAVR mkII USB
    an PIND.6 das Poti (voll aufgedreht -> 5.0 V) AIN0 = SOLL
    an PIND.7 Ausgangsleitung vom Sensor AIN1 = IST

    Daher dachte ich auch, daß mir ein Interrupt,
    wenn die 5V anliegen, reicht.

    Bin halt nicht so der Elektroniker und stehe
    erst am Anfang.

    PS: Ich hab da noch ein Spielzeug von Conrad
    (4 LKW-Töne betrieben mit 2 Mignon AALR6).
    Davon will ich später so einen Hupenton bei
    Eintritt einer Person erklingen lassen. Muß ich
    dazu ein Relais zum Schalten haben oder geht so
    was evtl. über Pins ? Einen Schließer hab ich schon
    mal vom Spielzeug abgetrennt, siehe Anhang.
    Miniaturansichten angehängter Grafiken Miniaturansichten angehängter Grafiken img_0002_927.jpg  

  4. #4
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    15.01.2007
    Ort
    Göttingen
    Beiträge
    705
    So einen Schließer kann man ganz einfach mit einem Transistor ersetzen. NPN wenn der Kontakt nach Masse geschaltet wird, und PNP wenn der Kontakt mit +Ub verbunden werden muss.

    Muss der Kontakt denn eine bestimmte Zeit lang geschlossen werden (also so lange das Tonsignal abgegeben werden soll), oder reicht ein einmaliges kurzes "triggern"? Dann würde ich das in der Tat mit ´nem Transistor machen, der direkt vom High-Signal des Sensors durchgeschaltet wird. Dafür wäre ein Mikrokontroller die berühmte Kanone, mit der auf Spatzen geschossen wird

    Hast Du denn ein einfaches Voltmeter, mit dem man das überprüfen könnte?

  5. #5
    Neuer Benutzer Öfters hier
    Registriert seit
    17.01.2009
    Ort
    ILLINGEN
    Alter
    59
    Beiträge
    21
    Ein Voltmeter hab ich. Da kommen
    auch die 5 V vom Sensor an.
    zu dem anderen :
    Mit Transistoren kenn ich mich nicht so aus.
    Hatte gehofft, daß ich einen der beiden
    Taster auf dem Board mißbrauchen könnte.
    Da sind ja auch je zwei PINs dran. Mit einer
    Klammer könnte man den Taster gedrückt
    halten und dann bei Bedarf über die PINs
    aktivieren. Das geht aber so wahrscheinlich
    nicht.
    Das ganze soll etwa 2-3 Sekunden lang
    geschalten werden. Solange dauert etwa das
    Abspielen des Tones.
    Zur Not hätte ich da noch ein serielles Board
    mit 8 Relais zum Schalten. Eine Mini-Platine
    (hat mir jemand mal gemacht) mit einem
    Max232, 5 Elkos 100nF und 9poligem Ausgang
    hätte ich auch noch da liegen. Das Board ist
    von Conrad und läuft auf dem PC mit selbst-
    geschriebener Software (XProfan) sehr gut.

    Müßte ja auch gehen, da das Board eine externe
    Spannungsversorgung hat und damit ja nur die
    Steuerbefehle gesendet werden müssen.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •