-         

Ergebnis 1 bis 4 von 4

Thema: I²C an M-Unit 2.0

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    04.10.2006
    Alter
    29
    Beiträge
    23

    I²C an M-Unit 2.0

    Anzeige

    Guten Abend

    Habe da eine Frage bezüglich des I²C Busses. Wenn ich den I²C nutzen möchte habe ich hier bisher nur die Variante gesehen, dass der Port 9 und 10 für SDA und SCL genutzt wird. Diese Anschlüsse sind aber ja auch an dem seitlichen 6 polige Stecker vorhaneden. Wie kann ich diese nutzen oder im Programm definieren?

    Schöne Feiertage noch

  2. #2
    Neuer Benutzer Öfters hier
    Registriert seit
    04.10.2006
    Alter
    29
    Beiträge
    23
    Versuche seid einiger Zeit den SD20 über I²C anzusteuern. Habe dazu folgendes Programm gefunden. Aber es funktioniert so leider nicht. Die Adresse des SD20 ist ja laut dem Datenblatt "0xC2" was bedeutet das? Ich habe jetzt einfach mal angenommen, dass die C2 im hexadezimalen Zahlensystem steht und somit im Dez. eine 194 ergibt. Habe es im Programm auch schon versucht zu ändern, bekomme aber dennoch keine Servos angesteuert. Woran kann es liegen? Angeschlossen ist alles richtig und Resonator schwingt.

    Link zum Programm

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    04.10.2006
    Alter
    29
    Beiträge
    23
    Habe mein Problem endlich gelöst. Ich hatte keine Widerstände gegen positives Potential bei dem Bus. Ich hoffe es schütteln sich jetzt nicht alle den Kopf

  4. #4
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    16.09.2004
    Ort
    Schwabenland
    Beiträge
    156
    Ja, das sind meistens die Standardfehler. Passiert vielen beim ersten Mal.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •