-         

Ergebnis 1 bis 3 von 3

Thema: Problem: Ultraschallsensoren sind sehr ungenau

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    25.11.2009
    Beiträge
    7

    Problem: Ultraschallsensoren sind sehr ungenau

    Anzeige

    Hallo,

    Wir haben ein Problem. Unsere Ultraschallsensoren sind sehr ungenau. Wenn irgendwas in 10 cm Entfernung steht, kommt in 8/10 Fällen irgendwas in der Region von 1,5 m als Ergebnis zurück.

    Wenn ich dann auf 5 cm Entfernung gehe, naja, dann funktioniert es so halberwege. Zumindest in 9/10 Fällen.

    Auch wenn ich irgendwie am Poti dreh, ändert sich nicht wirklich was.
    Was passiert denn, wenn man den nach ganz links oder rechts dreht. Technisch ändere ich den Widerstand, aber wie wirkt sich das dann auf die ermittelte Entfernung zurück?

    Und warum bekommen wir größer 6-7 cm Entfernung nur noch falsche Werte?

    Nach meinen Recherchen können die Teile doch zumindest bis 1 Meter Hindernisse erkennen. (Mir würden ja schon 30 cm reichen, weil wir nur durch ein Labyrinth fahren müssen.)

  2. #2
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    04.11.2008
    Beiträge
    131
    Ich kann dir leider auch nicht viel helfen. Aber evtl. hilft dir der Link.
    http://www.asurowiki.de/pmwiki/pmwik...fernungsmesser

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    25.11.2009
    Beiträge
    7
    Konnte das Problem etwas lösen, indem ich den Poti ganz nach links gedreht habe. Nun kann er so ca. bis 20 cm ne Wand erkennen, was für meine Zwecke völlig ausreicht.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •