-         

Ergebnis 1 bis 3 von 3

Thema: Problem mit RS232, kein input im terminal

  1. #1
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    04.01.2008
    Alter
    24
    Beiträge
    540

    Problem mit RS232, kein input im terminal

    Anzeige

    moin moin,

    ich habe mir mit einem max232 eine adapterplatine gebastelt, um einen AVR über RS232 mit dem pc zu verbinden. als terminal verwende ich den hercules von HW-Group, habs aber auch schon mit Hyperterminal versucht. das Problem: wenn ich etwas sende, kommt im terminal nichts an. das komische ist, dass der cursor im ausgabefenster flackert, wenn ich daten sende, also müsste ja etwas ankommen. mein controller ist ein atmega32 mit 16mhz quartz.

    mfg roboman
    ...and always remember...
    ...AVR RULES...

  2. #2
    Erfahrener Benutzer Robotik Visionär Avatar von Hubert.G
    Registriert seit
    14.10.2006
    Ort
    Pasching OÖ
    Beiträge
    6.183
    Wenn es geht den Mega32 heraus nehmen und zwischen RX und TX eine Brücke stecken.
    Dann eine Eingabe auf dem Terminal machen, das sollte als Echo zurück kommen.
    Grüsse Hubert
    ____________

    Meine Projekte findet ihr auf schorsch.at

  3. #3
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    04.01.2008
    Alter
    24
    Beiträge
    540
    so, dass war jetzt mal ganz dumm. nach 5 min nach dem post hab ich den fehler gefunden: das programm im AVR war net von mir, ich hatte nur die hex-file. in der doku steht, der port läuft mit 9600 baud. als ich zum test mal im terminal auf 600 baud umgestellt habe, geht alles.

    mfg roboman
    ...and always remember...
    ...AVR RULES...

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •