-         

Ergebnis 1 bis 4 von 4

Thema: RN-Mega 128 Funk keine Verbindung möglich

  1. #1

    RN-Mega 128 Funk keine Verbindung möglich

    Anzeige

    Hallo an alle,

    da die Suchfunktion bei mir SQL-Errors erzeugt und ich beim Duchklicken auch nicht fündig geworden bin starte ich ein neues Thema.

    Mein Vorhaben:
    per RN-mega 128 Funk Board, dass in einer Fernbedienung mit den RN-Joysticks verbaut ist, soll ein Messstand ferngesteuert werden. Das Board wird momentan mit 12,6V versorgt und nimmt sich 0,07A. Zum Empfang ist in dem Empfänger-PC das RN-Funk 1.1 Board verbaut, dass die Funksignale in die COM-Schnittstelle übertragen soll. Es erhält 12V vom Netzteil des PCs.

    Und nun gehen die Probleme los:
    Ein einfaches leicht abgewandeltes Programm von der Robotikhardware CD habe ich mit Bascom auf das mega128 fehlerfrei übertragen. Als Baudrate sind 9600 eingestellt. Wenn ich nun über Bascom den Terminal-Emulator ausführe, kommt da einfach nichts an. Ich habe die Baudraten gewechselt, die verschiedenen COMs ausprobiert und weiter rumvariiert. Der Funk scheint nicht zu funktionieren.

    Meine Frage: wie kann ich eingrenzen, wo das Problem liegt? Gibt es da eine Möglichkeit herauszufinden, ob der Fehler im RN-Mega oder im RN-Funk liegt? (Von Zusammenbaufehlern gehe ich dabei nicht aus, es hat vor einiger Zeit schonmal funktioniert.)

    Also hab ich dann versucht eine kabelgebundene Lösung zu finden. Das funktioniert auch soweit. Nun habe ich ein Programm geschrieben was die Joystick-Positionen ausgibt. Der linke ist nur für X-Bewegung gedacht, der rechte nur für Y. Die Werte werden nach dem Prinzip "<Wert X> <Wert Y>" ausgegeben. Ein Matlab-Porgramm liest die Schnittstelle aus und soll die Werte dann interpretieren.

    Aber: ich kriege immer nur "1023 1023" angezeigt, es findet keine Veränderung der Werte statt, wenn ich die Sticks bewege!

    Ich hoffe, jemand von euch kann mir behilflich sein. Sonst muss ich mich nach einer Alternative umschauen, wobei mir die Zeit langsam aber sicher im Nacken sitzt.

  2. #2
    Erfahrener Benutzer Robotik Visionär Avatar von Hubert.G
    Registriert seit
    14.10.2006
    Ort
    Pasching OÖ
    Beiträge
    6.186
    Der Wert 1023 deutet darauf hin das am ADC-Eingang dauernd die max. Spannung anliegt.
    Kontrollieren ob sich die Spannung auch ändert wenn der Stick bewegt wird.
    Grüsse Hubert
    ____________

    Meine Projekte findet ihr auf schorsch.at

  3. #3
    @Hubert.G
    Danke für den Hinweis, nach etwas rumsuchen und probieren habe ich meinen Fehler im bascom-text gefunden. Ich hatte "Reference = Avcc" gelöscht.

    Gibt es eine Lösung für mein Funk-Problem?

    Dankeschön

  4. #4
    Erfahrener Benutzer Robotik Visionär Avatar von Hubert.G
    Registriert seit
    14.10.2006
    Ort
    Pasching OÖ
    Beiträge
    6.186
    Ob etwas gesendet wird, lässt sich nur mit einem zweiten Empfänger feststellen von dem sicher ist das er funktioniert. Das wird dir aber nicht viel helfen.
    Wenn es schon mal funktioniert hat, hast du sicher nur eine Kleinigkeit verändert oder verstellt.
    Grüsse Hubert
    ____________

    Meine Projekte findet ihr auf schorsch.at

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •