-
        

Ergebnis 1 bis 3 von 3

Thema: RN-Control spinnt?

  1. #1
    Benutzer Stammmitglied
    Registriert seit
    06.11.2005
    Beiträge
    58

    RN-Control spinnt?

    Anzeige

    Hallo,

    seit neustem habe ich das Problem, wenn ich eine analoge spannung am Port a messen möchte (über einen Spannungsteiler), dann flackern die Werte. Die Schwankungen betragen bis zu einem Volt, ich glaube nicht, dass das normal ist. Sobald ich einen Finger auf das Board lege, also auf irgend eine metallische Fläche, dann bleibt der gemessene Wert stabil. An Wacklern liegt es nicht, habs schon ausprobiert.
    Komisch ist auch, dass, wenn ich nichts an den Ports dranliegen habe, der Wert (bzw. die Spannung) für PortA3 niedriger ist als bei den anderen Eingängen:
    Analog3 = 944 = 4.60937500 Volt im Unterschied zu,
    Analog0 = 1023 = 4.99511720 Vol

    Als Programm nehm ich das orginale Test Programm (in C) für das Board. Dadurch erkennt er z.B. fälschlicherweise Taster, die ich gar nicht gedrückt habe.
    Ich hoffe, ihr könnt mir weiter helfen!


    MfG
    Palmer

  2. #2
    Erfahrener Benutzer Robotik Visionär Avatar von Hubert.G
    Registriert seit
    14.10.2006
    Ort
    Pasching OÖ
    Beiträge
    6.183
    Offene ADC-Eingänge zeigen immer irgend eine Spannung an die schwankt.
    Ansonsten könnte das ein Masseproblem sein.
    Grüsse Hubert
    ____________

    Meine Projekte findet ihr auf schorsch.at

  3. #3
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    20.07.2009
    Ort
    Wien
    Beiträge
    131
    ist der spannungsteiler zu hochohmig? es gibt bei atmel eine appnote zum ADC der AVR-reihe, da wird auf einige mögliche probleme eingegangen.

    cm.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •