-         

Ergebnis 1 bis 5 von 5

Thema: Fusebits in PonyProg

  1. #1
    Benutzer Stammmitglied
    Registriert seit
    13.09.2009
    Alter
    22
    Beiträge
    43

    Fusebits in PonyProg

    Anzeige

    Hy
    Ich hab mir vor kurzem bei Pollin das Atmel Evaluations-board gekauft.
    Mein Problem: Ich möchte den Microcontroller (Atmega32) nicht mit dem internen Takt von 1Mhz betreiben, sondern sofort mit den vollen 16 Mhz arbeiten.
    Ich programmiere zwar in Bascom, aber da mein Laptop keine RS232 Schnittstelle hat, musste ich alles über USB programmieren.
    Zum Programmieren verwende ich PonyProg, leider weiß ich nicht, wie man die Fusebits umstellen muss, damit mein Atmega auf den externen 16 Mhz Quarz umschaltet...kann mir bitte einer von euch erklären was ich umstellen muss?
    Danke schon mal im voraus!!
    lg masterchief

  2. #2
    Erfahrener Benutzer Robotik Visionär Avatar von oberallgeier
    Registriert seit
    01.09.2007
    Ort
    Oberallgäu
    Beiträge
    7.557
    Hi,

    willkommen im Forum. Hol Dir mal den Fuse-calculator:
    http://www.engbedded.com/fusecalc/
    Dann etwa so:
    Ext. Crystal/Resonator High Frequ.; Start-up time: 16K CK + 64 ms; [CKSEL=1111 SUT=11]
    SPI enabled;
    JTAG schaltest Du vermutlich (erstmal) ab => disabled

    ... und aufpassen: die Darstellungsweise kann missverständlich sein, weil ne "1" gelöscht heißt. Stell im Fusecalculator "oben" die genannten Optionen ein, danach guck auf "Manual fuse bits configuration" - dort wäre dann NUR EIN Häkchen - das bei SPI. So läufts jedenfalls bei mir ganz ok.
    Ciao sagt der JoeamBerg

  3. #3
    Benutzer Stammmitglied
    Registriert seit
    13.09.2009
    Alter
    22
    Beiträge
    43
    Danke für die schnelle Antwort!!
    Weißt du zufällig ob in PonyPorg die Häkchen invertiert sind oder nicht (halt wie ich die Häkchen setzen muss)?
    lg masterchief

  4. #4
    Erfahrener Benutzer Robotik Visionär Avatar von oberallgeier
    Registriert seit
    01.09.2007
    Ort
    Oberallgäu
    Beiträge
    7.557
    Das habe ich (rein-) editiert - da warst Du vermutlich zu schnell *gggg*.

    Im PonyProg setz nur das SPI-Häkchen.
    Ciao sagt der JoeamBerg

  5. #5
    Benutzer Stammmitglied
    Registriert seit
    13.09.2009
    Alter
    22
    Beiträge
    43
    *gg*
    Ich werde es morgen gleich ausprobieren und dann berichten ob ich ihn verfused hab oder ob er jetzt mit dem externen Quarz funzt. \/

    Sry hat etwas länger gedauert...hatte ein wenig Stress mit Schulbeginn und meinem neuestem Projekt: einem Hexapod!!
    Zurück zum Atmega32...es hat gefunzt!! Vielen Dank nochmal!!

    lg masterchief

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •