-         

Ergebnis 1 bis 5 von 5

Thema: RN Control - Frequenzproblem

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    10.02.2009
    Ort
    NRW
    Alter
    47
    Beiträge
    19

    RN Control - Frequenzproblem

    Anzeige

    Hallo !

    Ich habe mir ein RN Control zusammengelötet (auf vorgefertigter Platine).

    Nun versuche ich das C Demoprogramm zu kompilieren:

    avr-gcc rncontrol.c -c -o rncontrol.o -Os -g -mmcu=atmega32 -std=gnu99 -DF_CPU=16000000

    Die Fusebits sind so:

    avrdude: safemode: lfuse reads as EF
    avrdude: safemode: hfuse reads as D9
    avrdude: safemode: Fuses OK

    gesetzt.

    aus dem Calculator: http://npshare.de/files/0bc28e99/fusebits.pdf

    Wenn ich das Programm auf den Controler lade, bekomme ich nur ein sehr tiefes Brummen.

    Kann das auch ein Problem mit meinem Frequenzgenerator sein ?

    Danke

    Gruß

    linrobot

  2. #2
    Erfahrener Benutzer Robotik Visionär
    Registriert seit
    26.11.2005
    Ort
    bei Uelzen (Niedersachsen)
    Beiträge
    7.942
    Die Fuse Werte sehen nicht so verkehrt aus. Besser wäre wohl den Brownout Level noch auf 4 V zu stellen, denn 16 MHz sind zu viel für 2,7 V. Außerdem sollte man den BOD auch einschalten, wenn es keine wirklichen Grund dagegen gibt (Batteriebetreib mit sehr wenig Strom). Das wäre dann 0x2F und 0xD9 für die Fuses.

    Trotz allem sollte es schon mit den Fuses gehen.

    Der Aufruf von GCC mit den gezeigten Pramemtern erzeugt noch kein fertiges binary oder .hex file, sondern nur das File rncontrol.o. Könnte es sein das da noch ein anderes altes Porgramm genutzt wird ?

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    10.02.2009
    Ort
    NRW
    Alter
    47
    Beiträge
    19
    Ich habe mir dieses Build-Script geschrieben:

    http://de.pastebin.ca/1544666

    Ich werde das noch einmal mit den neuen Fusebits probieren.

  4. #4
    Neuer Benutzer Öfters hier
    Registriert seit
    10.02.2009
    Ort
    NRW
    Alter
    47
    Beiträge
    19
    Funktioniert mit den neuen Fusebits auch nicht ? Irgendwelche Ideen zur Fehlersuche ?

    Das Demoprogramm, was vorkompiliert dabei war läuft richtig. Ist vielleicht ein Fehler in avr-gcc ? Muss ich einen anderen Controler Typ auswählen ?
    Linux - as free as in freedom

  5. #5
    Neuer Benutzer Öfters hier
    Registriert seit
    10.02.2009
    Ort
    NRW
    Alter
    47
    Beiträge
    19
    Es scheint ein Problem mit der Steuerungsfunktion für den Beeper aus dem Demoprogramm zu sein.
    Linux - as free as in freedom

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •