-         

Ergebnis 1 bis 3 von 3

Thema: Programm geht nicht! warum?

  1. #1
    Benutzer Stammmitglied
    Registriert seit
    03.08.2009
    Ort
    SFB
    Beiträge
    60

    Programm geht nicht! warum?

    Anzeige

    Wollte mal wissen ob jemand weiß warum das programm nicht auf den taster reagiert?

    $regfile = "m8def.dat"
    $crystal = 3686100
    $hwstack = 100
    $swstack = 100
    $framesize = 100



    Config Lcdpin = Pin , Db4 = Portd.4 , Db5 = Portd.5 , Db6 = Portd.6 , _
    Db7 = Portd.7 , E = Portd.3 , Rs = Portd.2
    Config Lcd = 16 * 2


    Cls
    Locate 1 , 3
    Lcd "Starte,"
    Locate 2 , 1
    Lcd "Bitte warten"
    Wait 1

    Config Portc.0 = Input
    Taster Alias Portc.0
    Taster = 1

    Cls
    Locate 1 , 5
    Lcd "Ready.." : Waitms 100

    Do
    If Taster = 0 Then
    Waitms 100
    If Taster = 0 Then
    Gosub Ich
    End If
    End If

    Loop

    Ich:
    Locate 1 , 1
    Lcd "teste."
    Locate 2 , 1
    Lcd " test2"
    Waitms 100
    Cls
    Locate 1 , 1
    Lcd " testeee"
    Wait 2
    Return

  2. #2
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    16.02.2006
    Beiträge
    1.112
    Wenn du die Eingangswerte abfragen willst, musst du Pinc.0 benutzen. Also in deinem Fall
    Taster alias Pinc.0

    Gruß

    Rolf

  3. #3
    Benutzer Stammmitglied
    Registriert seit
    03.08.2009
    Ort
    SFB
    Beiträge
    60
    Danke so einfach der Fehler.....

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •