-         

Ergebnis 1 bis 3 von 3

Thema: LCD 2x16 zeigt nur 2x 8 an

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    14.05.2009
    Beiträge
    13

    LCD 2x16 zeigt nur 2x 8 an

    Anzeige

    Hallo zusammen,
    ich habe noch ein LCD hier rumfliegen gehabt welches ich an meinen Atmega8 angeschlossen habe. Leider werden nur 2x8 Ziffern angezeigt. Ich weiß nur dass der eine Chip des LCD der HD44100H ist, der andere Chip hat einen Aufkleber drauf.F93621.Soll ich den Aufkleber abmachen? Evtl. steht noch was darunter.Könnte es daran liegen dass eventuell die 4 Datenleitungen die auf Masse gelegt werden sollen, nicht richtig polen? Oder sind bestimmte Datenleitungen für den rechten Ziffernbereich zuständig so dass ich diese nochmal nachlöten sollte.
    Woran könnte es sonst liegen? Habe mal ein Bild mit eingestellt.
    Achja: Das LCD benötigt eine negative Spannung für den Kontrast.
    Quellcode:

    $regfile = "m8def.dat"
    $crystal = 3686411
    $baud = 9600

    Ddrd = &HFE
    Config Lcdpin = Pin , Db4 = Portd.4 , Db5 = Portd.5 , Db6 = Portd.6 , Db7 = Portd.7 , E = Portd.3 , Rs = Portd.2
    Config Lcd = 16 * 2

    Cls
    Locate 1 , 1
    Lcd "Hallo Hallo"
    Locate 2 , 1
    Lcd "Guten Tag"

    gruß
    Holger

  2. #2
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    16.02.2006
    Beiträge
    1.112
    Versuche mal, in die dritte und vierte Zeile zu schreiben.
    Evtl. auch mal ein 16 * 4 Display. Manche LCD sind anders organisiert.
    Wenn unter dem Aufkleber kein HD44780 sondern ein KS077 ist, dann musst du den entsprechenden Chipset im Config LCD angeben.

    Gruß

    Rolf

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    14.05.2009
    Beiträge
    13

    LCD Display

    Hallo,
    ich habs mit 4 Zeilen und 16x4 probiert. Hat leider nicht funktioniert.
    Ich benute den myavr Controller mit USB. Ich habe + und - und Kontrast an ein externes Netzteil angeschlossen mit 5V Gleichspannung (bzw. -5V). Der Rest läuft über den USB Anschluß des Controllers. Die Massepotentiale habe ich über den Lo pin miteinander verbunden. Kann es sein das der Strom vom USB Port nicht ausreicht obwohl ich das LCD über ein ext. Netzteil angeschlossen habe? Kann ich die 5V Gleichspannung des Netzteils auf den Hi Pin des AV RControllers einleiten?
    Der zweite Chip des LCD Displays ist übrigens ein HD44780.
    Gruß
    HOlger

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •