-
        

+ Antworten
Ergebnis 1 bis 4 von 4

Thema: schaltung resetet sich bei funke :(

  1. #1
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    29.09.2004
    Beiträge
    135

    schaltung resetet sich bei funke :(

    Anzeige

    Ich hab mir meine Schaltung mit einem Atmega aufgebaut und funktioniert wunderbar !!
    Wenn ich aber in der nähe der Schaltung einen Schalter oder einen Stecker irgendwo reinstecke ( so das ein Funke überspringt) dann resetet der Microcontroller sich. muss ich, um das vorzubeugen, einen kondensator zwischen + und - anschliessen, 100nF ?

  2. #2
    Administrator Robotik Einstein Avatar von Frank
    Registriert seit
    30.10.2003
    Beiträge
    4.956
    Blog-Einträge
    1
    Ja, solltest du in jedem Fall machen. Möglichst nahe am Controller

  3. #3
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    29.09.2004
    Beiträge
    135
    alles klar, mach ich - danke dir

  4. #4
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    20.06.2004
    Beiträge
    256
    Für die Zukunft, pro IC ein 100n Kondensator schadet nie, verhindert aber evtl. solche Effekte. Früher hies es mal dann noch alle zwei ICs einen 10µ Kondensator. Ist bei heutigen ICs teilweise nicht unbedingt erforderlich, schaden tut es aber nicht.

    Falls das alles auch nicht hilft, probiere mal eine kleine Induktivität (so 10µH) in die 5V und Masse-Leitung des Controllers oder der gesammten Schaltung einzuschleifen. Das bewirkt manchmal auch Wunder.
    BlackBox

+ Antworten

Berechtigungen

  • Neue Themen erstellen: Ja
  • Themen beantworten: Ja
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •