-         

+ Antworten
Ergebnis 1 bis 4 von 4

Thema: Paralelle Schnittstelle hinüber?

  1. #1
    Gast

    Paralelle Schnittstelle hinüber?

    Anzeige

    Hallo, das ist mein erster Beitrag in diesem Forum. Trotzdem komm ich mal gleich zur Sache.

    Also ich habe mir einen "Cam"oboter gebaut. Mit dem konnten Besucher meiner Internetseite meine Webcam beliebig bewegen. Ich habe mit PHP eine Steuerkonsole gemacht, die die Daten an eine Delphianwendung weitergegeben hat. Delphi hat dann einfach an der paralellen Schnittstelle am enstprechenden Port einen Transistor geschaltet, und der hat das entsprechende Relai geschaltet.
    Soweit zur Technik.
    In letzter Zeit hatte ich keine Lust mehr das Teil zu benutzten, da lags 2 Wochen auf der Fensterbank. Als ich es letztens wieder angeschlossen hab, ging es nicht mehr richtig. Ich hab alles durchgemessen. Und der Fehler liegt irgendwo bei der Paralellen Schnittstelle, denn wenn ich Pin 1 beschalte, sollten da ja eigentlich 5V anliegen und wenn ich Pin 1 auf 0 setze, logischerweise 0.
    Schön wärs.
    Bei Pin 1 liegen jetzt immer 5V. Egal was ich schalte.
    Bei Pin 2 lagen sonst immer 4,irgendwas. Jetzt liegen bei "aus" 0,09V. Bei "an" sagenhafte 0,12V.
    Ähnlich bei Pin 3:
    "AN": 3,44V
    "AUS:" 2,99V
    --
    Ich mittlerweile alles nach dem Fehler durchsucht.
    Vom Steuerprogramm kommt er nicht, denn die Spannungen sind auch schon beim Hochfahren auf den besagten Werten.
    -
    Dann hab ich im Bios die Einstellungen ALLE durchprobiert.
    Jetzt steht der LPT wieder auf : EPP 1.9
    -
    Achja vllt noch wichtig.
    Ich benutze Delphi 7 auf Windows 2000 und steuere den LPT per IO.dll.

    Nehmen wir an meine paralelle Schnittstelle ist hinüber.......was kann ich tun? Ich habe wenig lust meinen ganzen Delphi Server umzuschreiben.
    Was ist mit diesen USB zu LPT konvertern? Kann ich die ohne weiters einsetzen, bzw genauso wie den richitgen LPT programmieren?


    Grüße Max.

  2. #2
    Argh, nix da "Gast".
    Wozu hab ich mich denn angemeldet ?
    Wird wohl wieder an meinen Cookies liegen, sorry
    Max

  3. #3
    Ich hab mal irgendwo gelesen, dass "falsches Beschalten" des par. Ports ziemlich gefährlich sein kann und das einige Chipsets letztlich den Dienst quitieren können.
    Ich hab leider nur einen mäßigen Tip: PCI Parallelport-Karte kaufen und die Adresse im Programm ändern.
    Schutzschaltungen verwenden! (

  4. #4
    Gast
    probier die schnittstelle doch mal mit einem drucker aus, nach meinen erfahrungen sind die lpts sehr widerstandsfähig ich hab jedenfalls noch keinen kaputt gekriegt. btw: die idee mit der webcam hatte ich auch, bei mir kommt die aber auf eine wlanstation im freien

    MfG Christoph

+ Antworten

Benutzer, die dieses Thema gelesen haben: 0

Derzeit gibt es keine Benutzer zum Anzeigen.

Berechtigungen

  • Neue Themen erstellen: Ja
  • Themen beantworten: Ja
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •