-         

Ergebnis 1 bis 4 von 4

Thema: Atmega16 + 4067 Multiplexer Messwerte rauschen

  1. #1

    Atmega16 + 4067 Multiplexer Messwerte rauschen

    Anzeige

    SMARTPHONES & TABLETS-bis zu 77% RABATT-Kostenlose Lieferung-Aktuell | Cool | Unentbehrlich
    Moin zusammen,

    ich hab eine Schaltung gebaut mit einen ATmega16 und 4067 Multiplexer.
    An den Eingägngen hängen Potis die ausgewertet werden sollen.
    Die Messergebnisse schwanken aber sehr stark.

    Per Software bilde ich den Mittelwert aus 4 Messungen und wandel dieses Ergebniss dann in 7bit
    um und versende es anschließend per Midi an einen PC.
    Dieser Wert schwankt dann immer noch um +-5.

    Am Multiplexer hab ich 1 100nf Ablockkondensator.
    Und Beim AVR 1 100nf von Aref nach GND, 1 von VCC nach GND und ein von AVCC nach GND. Die Eingänge am AVR direkt rauschen nicht.

    Kann mir einer Tipp geben was ich falsch gemacht habe.

  2. #2
    Erfahrener Benutzer Robotik Visionär Avatar von Hubert.G
    Registriert seit
    14.10.2006
    Ort
    Pasching OÖ
    Beiträge
    6.183
    Vielleicht hat das damit was zu tun
    http://www.roboternetz.de/phpBB2/vie...0b4170ba8bc588
    Grüsse Hubert
    ____________

    Meine Projekte findet ihr auf schorsch.at

  3. #3
    Erfahrener Benutzer Robotik Visionär
    Registriert seit
    26.11.2005
    Ort
    bei Uelzen (Niedersachsen)
    Beiträge
    7.942
    Irgendwas scheint mit den 4067 faul zu sein. Mit dem kleineren 4051 usw. hatte ich bisher nie Probleme. Normalerweise sollte der 10 Bit wert um etwa 1 LSB Schwanken, vielleicht auch mal 2.

    Könnte es ein Softwareproblem sein, mit zu hoher Taktfrequenz oder dauerndem umschalten der Referenz ?

  4. #4
    Hab den Fehler gefunden. Hab im Datenblatt übersehen das der Enable Pin Lowactive ist. Frag mich nur, warum der vorher überhaupt auf die verschiedene Potis reagiert hat.

    Trotzdem Vielen Dank für die Lösungsvorschläge.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •