-         

Ergebnis 1 bis 4 von 4

Thema: Eagle 5, Kondensator mit Package für RM 2,54 und 5,08

  1. #1

    Eagle 5, Kondensator mit Package für RM 2,54 und 5,08

    Anzeige

    Guten Abend!

    Ich möchte mir in Eagle 5 ein flexibles Device für ungepolte Kondensator entwerfen. Dieser soll ein Package bekommen in das Kondensator mit einem Rastermass von 2,54 und 5,08 passen.

    In der mitgelieferten Lib "capacitor-wima.lbr" findet man unter Device "C-" so etwas ähnliches. Allerdings ist bei diesem Device ein Symbol mit drei Pins (genannt C2, zwei Pins auf der einen Kondensaorseite und einen auf der anderen) verwendet worden. Auch das verwendete Package (z.B. "C2.5/5-2") hat drei Pads, die aber nicht miteinander verbunden sind. Jeder der Pins ist in der Devicedefinition mit einem der Pads connected. Je nach dem welchen Pin man im Schaltplan anklickt entsteht eine Luftlinie zu einem der Pads. Mir leuchtet der Sinn eines solchen Vorgehens nicht ein, da man hier schon beim Schaltplanzeichnen genau wissen muss was für einen Bauform beim Kondensator verwendet werden soll und man kann gleich ein normales, aber unflexibles Package wählen. Und genau das möchte ich vermeiden.

    Ich habe nun einen der beiden auf einer Seite befindlichen Pins im Symbol gelöscht. Dadurch ist natürlich auch ein Pad in der Devicedefintion unconnected. Dann habe ich im Layer 17 "Pads" die beiden Pads mit drei sich leicht überlappenden Wires verbunden.

    Das sollte eigentlich auf der Platine eine Platz für einen Kondensator entweder mit RM2,54 oder RM 5,08 ergeben. In der Bildschirmansicht und im Ausdruck scheint das auch alles so weit zu funktionieren.

    Allerdings gibt der DR-Check für alle solche Devices einen "Layer Abuse"-Fehler aus. Wobei mit ehrlich gesagt nicht ganz klar ist was dieser Fehler eigentlich genau bedeutet.

    Der Fehler ist sicherlich nicht tragisch. Aber gibt es nicht doch eine Lösung bei der der DRC ohne Fehler durchläuft?

    Ich hoffe, ich habe mich einigermaßen verständlich machen können. Und hoffe noch mehr, das jemand eine Lösung hat. Oder auch gern nur einen Tipp.

    Vielen Dank schon einmal.


    Bot-Builder

  2. #2
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    25.11.2003
    Beiträge
    1.111

    Re: Eagle 5, Kondensator mit Package für RM 2,54 und 5,08

    Zitat Zitat von Bot-Builder
    Der Fehler ist sicherlich nicht tragisch. Aber gibt es nicht doch eine Lösung bei der der DRC ohne Fehler durchläuft?
    Da kann man sich nie so sicher sein. In Deinem Fall liegt es daran, dass der Eagle in diesem Layer nur PADs bzw. Vias erlaubt und erwartet. Die Folgensind unterschiedlich.
    Die adäquate Lösung wäre, einen geeigneten Layer zu verwenden, aber ich kann Dir nicht sagen, welcher das wäre.
    Du kannst mal versuchen die Signallayer zu benutzen, aber das hat andere Nachteile. ZB, dass die Eigenschaften des 3. Pads durch die Signal-Layereigenschaften und nicht durch die PadEigenschaften bestimmt sind. Gehen tut das aber, hatte ich mal probiert.
    Gruß

  3. #3

    Re: Eagle 5, Kondensator mit Package für RM 2,54 und 5,08

    Zitat Zitat von Gock
    In Deinem Fall liegt es daran, dass der Eagle in diesem Layer nur PADs bzw. Vias erlaubt und erwartet.
    Also habe ich gerade die Wires aus dem Package entfernt und die beiden Pads durch ein weiteres, viertes Pad miteinander verbunden (als drei sich überlappende Pads auf einer Seite des Kondensators). Den Bohrdurchmesser des neuen Pads habe ich auf das kleinste mögliche Mass gesetzt.

    Aber auch mit der Lösung ist der DR-Check nicht einverstanden. Jetzt wird ein "Drill size"-Fehler gemeldet. Was klar ist, da als minimaler Bohrdurchmesser 31mil eingegeben ist.

    Also einen Fehler gelöst, einen neuen produziert.

  4. #4
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    25.11.2003
    Beiträge
    1.111
    Dann nimm doch anstatt eines Pads mit Loch einfach ein SMDPad, bzw. 2 Stück: von jeder Seite eins, wenn DU willst. Deren Größe kannst Du auch variieren.
    Es gibt noch die etwas unschöne Möglichkeit, 3 Pads zu nutzen und 2 davon im Schematic zu verbinden. Dann aber kann es passieren, dass der Autorouter relativ lange Leitungen zwischen den Pads verlegt.
    Jedenfalls sind dann die Fehlermeldungen weg.
    Grguß

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •