-
        

Ergebnis 1 bis 3 von 3

Thema: nur sporadische Kommunikation mit RFM12

  1. #1

    nur sporadische Kommunikation mit RFM12

    Anzeige

    Hallo,
    ich versuche über einen PIC ein RFM12 Funkmodul zu steuern. Zum Testen bekommt der PIC seinen Takt vom RFM12. Der PIC lässt eine LED blinken und sendet dem RFM12 den Befehl den Taktausgang auf 10MHz zu schalten. Die LED sollte anschliessend 10mal schneller blinken.
    Leider funktioniert das nur sehr sporadisch, erst bei 6 maligen Senden des Befehls ist die Chance hoch das die LED schneller blinkt.
    Ich habe Pausen zwischen jeder Signalveränderung(SDI, SCK), so das zu schnelles Senden kein Problem sein sollte, nach google-Recherche hab ich auch Abblockkondensatoren versucht(100nF Keramik), ebenfalls keine Veränderung.
    Hab die Schaltung 2 mal mit 2 verschiedenen RFM12 gebaut, und auch schon hier nach Hilfe gesucht: http://www.mikrocontroller.net/topic/136456
    Bin echt mit meinem Latein am Ende woran dieses Verhalten liegen könnte und wäre dankbar für ein paar Ideen.

    thanks in advance,
    -=)Hama(=-

  2. #2
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    04.04.2005
    Ort
    Hamburg
    Alter
    29
    Beiträge
    826
    Mh, bei deinem Quellcode kann ich dir in Ermangelung an Assembler Kenntnissen leider nicht weiterhelfen, deswegen würde ich mal das Augenmerk auf die Schaltung werfen.

    Worauf hast du diese aufgebaut? Nach welchem Schaltplan? Ist die Versorgungsspannung stabil? Funktionieren die anderen Funktionene sauber?

    Hast du auch keine kalten Lötstellen/wacklige Steckkontakte?
    www.subms.de
    Aktuell: Flaschcraft Funkboard - Informationssammlung

  3. #3
    danke erstmal für deine Antwort, also:
    Bei dem Assembler-Code bin ich mir eigentl recht sicher das der OK ist, ganz im Gegensatz zur Schaltung^^
    Das ganze ist auf einer Lochrasterplatine aufgebaut, wobei das RMF12 wegen SMD-Bauweise mit selbst angelöteten Drähten auf der Platine hängt.
    Den Schaltplan hab ich mir aus mehren Internetquellen zusammengesucht, er ist aber eigentl recht unproblematisch. Vom RFM12 aus gesehen:
    CLKOUT --> CLKIN vom PIC
    SDI --> I/O-Pin vom PIC
    SCK --> I/O-Pin vom PIC
    VDD und VCC an die Stromquelle
    (hab natürlich noch einiges probiert was ich so im Internet gefunden hab, wie nFFS mit 10kOHM nach VDD, nSel nach Masse und Abblockkondensator von VDD nach VCC, aber das hatte alles keinen Effekt)
    Als Versorgungsspannung verwende ich ein altes Rechner-Netzteil, hab aber auch NiMh-Akkus versucht(4Zellen = 4,8V und 3 Zellen = 3,6V), jedes mal exakt das gleiche Verhalten.
    An anderen Funktionen hab ich nichts getestet, das Umschalten des Taktausganges ist afaik das einzige was direkte Resonanz liefert. Für die eigentl Funktion bräuchte man ja 2Module die auf den gleichen Kanal etc eingestellt sind(was natürlich schwierig zu Bewerkstelligen ist)
    Weil ich wacklige Lötstellen ausschliessen wollte hab ich das ganze ja ein 2. mal aufgelötet, würde mich doch sehr wundern wenn mir genau das gleiche 2mal passiert wäre. Hab aber zugegeben 2 linke Hände, meinst du es hat Sinn das nochmal von jemanden mit ruhigerer Hand löten zu lassen?

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •