-
        

Ergebnis 1 bis 5 von 5

Thema: Probleme mit gehacktem Servo bzw. Servos allgemein?

  1. #1
    Benutzer Stammmitglied
    Registriert seit
    18.04.2005
    Alter
    32
    Beiträge
    84

    Probleme mit gehacktem Servo bzw. Servos allgemein?

    Anzeige

    SMARTPHONES & TABLETS-bis zu 77% RABATT-Kostenlose Lieferung-Aktuell | Cool | Unentbehrlich
    Hallo Leute,

    also habe heute 2 Servos gehackt also Poti und Anschläge entfernt und 2Stück 2,7k Widerstände als Dummy für die Elektronik eingelötet.

    Nun habe ich das Problem, dass sie in einer Richtung sehr schnell drehen, in der anderen aber verdammt langsam.
    Kann es sein, dass die Toleranzen so brachial sind?

    Ich habe dazu parallel (Spannung sowie Signal) einen Servo des selben Typs als nicht gehackten angeschlossen und dieser schien mir wesentlich schneller.

    Ich hatte nie wirklich viel mit RC- Sport zu tun und weiss echt nicht mehr um solche Problemstellungen.

    Gruß - Henning

  2. #2
    Erfahrener Benutzer Robotik Einstein Avatar von vohopri
    Registriert seit
    11.09.2004
    Ort
    südlich der Alpen
    Beiträge
    1.708
    Hallo Henning,

    das kann 2 Ursachen haben.

    Es ist möglich, dass die Impulserzeugung nicht sehr symmetrisch erfolgt. Das lässt sich mit der Soundkarte deines PC und einem Programm recht einfach beurteilen. So ein Programm heisst Softwareoszi. Ein richtiges Oszilloskop geht natürlich auch.



    Zweitens musst du die 2 Widerstände für den Spannungsteiler experimentell ermitteln. In Summe müssen sie ungefähr so viel Widerstand sie das entfernte Poti haben. Zunächst kannst du einen Festwiderstand und das Poti verwenden. Damit stellst du die symmetrische Arbeitsweise, die du brauchst ein. Anschliessend misst du den eingestellten Wert vom Poti und suchst einen entsprechenden Festwiderstand raus.

    Code:
    Original         Test           Fertig
     
      ----O            ----O           ----O
     |                |               | 
     -                -               -
    | |              | | R/2         | | R/2 
    |R|<--O          | |             | | 
    | |               -               -
     -                |----O          |----O
     |                -               -
      ----O          | | X           | | X
                     | |<--O         | |
                     | |              -
                      -               |
                      |                ----O
    Und ja, es liegt an den Toleranzen, aber das ist weder "brachial" noch ungewöhnlich.

    grüsse,
    Hannes

  3. #3
    Benutzer Stammmitglied
    Registriert seit
    18.04.2005
    Alter
    32
    Beiträge
    84

    ...

    werde mir auf jeden fall gleich mal die signale anschauen, aber da die anderen gut laufen...?!

    das mit dem widerstand versteh ich ehrlich gesagt nicht ganz, denn das zuvor eingebaute poti ist ja auch keinesfalls unsymetrisch.

  4. #4
    Erfahrener Benutzer Robotik Einstein Avatar von vohopri
    Registriert seit
    11.09.2004
    Ort
    südlich der Alpen
    Beiträge
    1.708
    Hallo Henning,

    das mit dem widerstand versteh ich ehrlich gesagt nicht ganz
    dann schreib einfach, was du nicht verstehst, damit ich mehr erklären kann.

    das zuvor eingebaute poti ist ja auch keinesfalls unsymetrisch
    damit hat das überhaupt nichts zu tun. Es geht um den Fall, dass die Regelelektronik im Servo asymetrisch reagiert. Im Normalbetrieb ist das kaum zu sehen, da der Fehler ausgeregelt wird. Im gehackten Betrieb wird der Fehler dann sichtbar. Teste den Vorschlag einfach, anstatt zu argumentieren.

    grüsse,
    Hannes

  5. #5
    Benutzer Stammmitglied
    Registriert seit
    18.04.2005
    Alter
    32
    Beiträge
    84
    Hi,

    also wohin der Widerstand muss versteh ich natürlich. Aber die Reaktion der Elektronik noch nicht ganz. Inzwischen reagiert mein Servo auch irgendwie egal auf welchen Impuls nur mit verschiedenen Geschwindigkeiten in ein und dieselbe Richtung.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •