-         

Ergebnis 1 bis 6 von 6

Thema: LCD an PCF8574P im I2C-Mode

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    29.01.2009
    Beiträge
    9

    LCD an PCF8574P im I2C-Mode

    Anzeige

    SMARTPHONES & TABLETS-bis zu 77% RABATT-Kostenlose Lieferung-Aktuell | Cool | Unentbehrlich
    Hallo Bascom Spezis,
    wer kann mir den Bascom Code für den Betrieb eines 16x4 LCD´s, angeschlossen an einem Port Expander PCF8574P, vermitteln, oder gar per email schicken? Würde mir 6 Port Pins sparen.
    Ich arbeite am Aufbau einer Roboter Steuerung mit Hilfe von RN-Control V1.4
    Der Betrieb zweier SRF02 sowie zweier GP2D12 im I2C-Mode läuft bereits.
    Die Mechanik des Roboters ( VECTOR-3) besteht seit 15 Jahren (100 cm Größe) und soll elektronisch auf den neusten Stand gebracht werden. Fotos können auf Anfrage übermittelt werden.
    Freue mich auf Antworten. Bin auch gerne zum Austausch von Erfahrungen bereit.

    VECTOR-3
    Miniaturansichten angehängter Grafiken Miniaturansichten angehängter Grafiken vector_3.jpg  

  2. #2
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    21.09.2004
    Beiträge
    264
    In Bascom wird ein I2C LCD untersützt. Es gibt die AN #118 dazu. Das ist eine Library und ein Beispiel. Du musst allerdings die richtige Verdrahtung zwischen PCF8574 und LCD haben. Bei meiner C-Control ist die Beschaltung z.B. anders.

    mfg

    Stefan

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    29.01.2009
    Beiträge
    9
    Besten Dank, Stefan, für die Unterstützung. Habe 2 Tage mich durch verschiedene Codes gewühlt, bis ich auch auf die AN#118 sties. Das LCD läuft nun auch, aber wenn - wie bei mir - noch 2 weitere SRF02 über I2C laufen, und die gemessene Entfernung im LCD angezeigt werden soll, verheddert sich das LCD in den Zeilen. Wahrscheinlich ist der Code vom Timing her noch nicht optimal! Abgesehen davon, wird das LCD sehr langsam!
    Kehre bis auf weiteres reumütig zum direkten Betrieb von PORTC (6 Pins) zurück.
    mfg
    Günther

  4. #4
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    21.09.2004
    Beiträge
    264
    An meinem I2C-Bus hängen ein LCD, ein MAX127 (12-bit AD-Wandler) und drei Eeproms. Das funktioniert einwandfrei. Vielleicht müssen deine Pullups auf dem Bus etwas kleiner gewählt werden. Bei mir kommt irgendwann auch noch ein SRF10 und vielleicht ein Beschleunigungssensor hinzu. Ich mache mir da keine Sorgen. Vielleicht solltest du mal andere Adressen des SRF02 testen.

    mfg

    Stefan

  5. #5
    Neuer Benutzer Öfters hier
    Registriert seit
    29.01.2009
    Beiträge
    9
    Pullups sind ja bereits im CN-Controll mit je 10k realisiert. Weitere sind nach meiner Kenntnis nicht erforderlich.
    Übrigens stammt mein Code und die Schaltung für LCDs im I2C-Mode aus dem Buch "Roboter selbst bauen", Seite 59/60. Lediglich der Code für die zwei SRF02 sind dazu gekommen.
    Der Code für Deine Anwendung würde mich interessieren! Will aber nicht unbescheiden sein, aber ich stehe noch am Anfang der Erfahrungen mit Bascom (seit Februar d. Jahres).

    Mfg

    Günther

  6. #6
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    21.09.2004
    Beiträge
    264
    Manchmal sind 10k zuviel. Es geht bis 4,7k runter.
    Der Code für das LCD steht in der AN118, den Max127 hast Du nicht und die SRF02 habe ich nicht

    mfg

    Stefan

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •