-         

Ergebnis 1 bis 5 von 5

Thema: Problem mit Schrittmotorsteuerung L297 & L298

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    07.03.2009
    Beiträge
    8

    Problem mit Schrittmotorsteuerung L297 & L298

    Anzeige

    Hallo User, ich bin der mumbelmann und habe ein Problem welches ich nicht ganz verstehe und hoffe, das mir der ein oder andere vielleicht helfen kann.

    Ich habe Diese Schaltung geroutet + geätzt (http://www.roboternetz.de/bilder/schaltungstep298.gif).

    Jedoch tut sich nichts... nicht einmal ein bisschen.

    Ich kann zwar die Referenzspannung prüfen und einstellen, mehr aber auch nicht.

    Versorgungsspannung an den IC´s habe ich auch.
    Normalerweise müsste doch nach dem Einschalten die Spulen des Motors doch theoretisch bestromt sein, so lange ich das Enable nicht auf GND gezogen habe. Leider kann ich keine Spannung an den Motor-Klemmen feststellen.

    Vielleicht hat der ein oder andere von euch einen guten Rat für mich.


    Ich wurschtel mal weiter und hoffe auf die ein oder andere Antwort.

    Merci mal ,

    Mumbelmann

  2. #2
    Neuer Benutzer Öfters hier
    Registriert seit
    07.03.2009
    Beiträge
    8
    Leider bin ich immernoch nicht weiter...
    ...gibt es denn keinen Erfahrenen User der vielleicht ein paar standart-Fehler kennt, die ich vielleicht übersehen haben könnte?

  3. #3
    Erfahrener Benutzer Roboter Experte Avatar von Neutro
    Registriert seit
    28.10.2007
    Ort
    Ostfriesland
    Alter
    38
    Beiträge
    642
    Hallo,

    mir ist aufgefallen das der Reset des L297 nicht beschaltet ist, da muss noch ein pull up dran.
    Hast du auch die Motor Spannung angelegt, am besten mit einem einstellbaren Netzteil langsam hochdrehen. Als Taktgeber kann man für die ersten Versuche super eine Astabile Kippstufe nehmen die mit 1Hz taktet (kann man schnell mit NE555 aufbauen)

    Gruß

    Neutro
    Jemand mit einer neuen Idee ist ein Spinner, bis er Erfolg hat.
    (Mark Twain)

  4. #4
    Erfahrener Benutzer Roboter Genie Avatar von Michael
    Registriert seit
    17.01.2004
    Ort
    Karlstadt
    Alter
    48
    Beiträge
    1.254
    Hallo mumbelmann,

    beliebte Fehler bei dieser Schaltung sind der fehlende Anschluß der Sense-Widerstände an GND
    und fehlende Verbindung GND Logik und GND Motorversorgung.

    Gruß, Michael

  5. #5
    Erfahrener Benutzer Roboter Experte Avatar von Neutro
    Registriert seit
    28.10.2007
    Ort
    Ostfriesland
    Alter
    38
    Beiträge
    642
    Mir ist da gerade noch etwas eingefallen was dir weiterhelfen könnte:
    http://www.roboternetz.de/phpBB2/dlo...le&file_id=284
    Lade dir mal das PDF runter und lese es dir aufmerksam durch. Da ist auch ein Schaltplan dabei nach dem ich meine Schrittmotorsteuerung (mit einigen
    Modifikationen) aufgebaut habe -> funktioniert.
    Jemand mit einer neuen Idee ist ein Spinner, bis er Erfolg hat.
    (Mark Twain)

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •