-
        

Ergebnis 1 bis 5 von 5

Thema: Schrittmotor ruckelt

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    10.02.2009
    Beiträge
    16

    Schrittmotor ruckelt

    Anzeige

    Heyho,
    Ich habe einen Schrittmotor(Sanyo Denki 103-770-1640 ) an eine l297/298 steuerung angeschlossen. Wenn ich jetzt eine brücke zwischen dem ground und dem schrittsignal-eingang setze, läuft der motor zwar einen schritt vorwärts, aber bei öfterem widerholen fährt er in unregelmäßigen Abständen in die entgegengesetzte Richtung. Als ich den Motor dann mit einem impulsgeber schneller fahren lassen wollte, machte er praktisch was er wollte und stotterte in beide Richtungen.

    Wo kann hier das Problem liegen? muss das Schritteingangssignal irgendwie moduliert sein? Die Umstellung auf Vollschritt hat auch nichts geändert.


    Gruß rhandy

  2. #2
    Erfahrener Benutzer Roboter Genie Avatar von BurningBen
    Registriert seit
    02.09.2008
    Ort
    Darmstadt
    Alter
    26
    Beiträge
    842
    schließ mal eine phase anders rum an.

    Vielleicht hilft das.
    Der l297 schaltet soweit ich weiss bei steigender Flanke, also dem wechsel von GND zu 5V

  3. #3
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    01.12.2005
    Ort
    @FFM
    Alter
    41
    Beiträge
    402
    du must darauf achten das die direction-inputs auf definierten pegeln
    liegen und nicht in der luft hängen
    sonst kommt es zu den von dir genannten phenomän

  4. #4
    Neuer Benutzer Öfters hier
    Registriert seit
    10.02.2009
    Beiträge
    16
    bin leider auf den absenden knopf gekommen..unten gehts weiter..

  5. #5
    Neuer Benutzer Öfters hier
    Registriert seit
    10.02.2009
    Beiträge
    16
    hiho,
    Mit den direction inputs meinst du wohl den CW/CCW pin. Der Pin ist nicht angeschlossen und hat nen Pull-up, daher sollte der keine Probleme machen.

    Ich habe versucht das ganze per Sps zu steuern. Ich steuere den Clock(einen (halb-)schritt machen) - GND Kreis über einen Optokoppler mit dem SPS Ausgangskreis.
    Nun habe ich da zwei mögliche Problemansätze:

    1. Das Signal , das den Schritt auslöst, muss auf bestimmter Weise moduliert sein. Im Beispielprogramm wird das "Low"-Signal eine uSekunde gehalten und dann (in der Schleife) 30ms auf High gesetzt.Eine SPS schafft das aufgrund ihrer himmlischen Lahmarschigkeit natürlich nicht.

    2.Molleonair schreibt etwas von definierten Pegeln.
    Ich habe zur Spannungsversorgung ein regelbares Netzteil zweckentfremdet, welches keine 5V sondern nur 4,8V bringt. Kann es möglich sein, das der Controller in diesem bereich "togglet"?

    @BurningBen:
    Ne, er schaltet bei fallender Flanke, daher auch ein pullup..

    Danke für euere Interesse, wenn euch was zu meinen Ansätzen einfällt, nur zu!

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •