-
        

Ergebnis 1 bis 6 von 6

Thema: Easyradio Probleme

  1. #1
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    05.05.2007
    Beiträge
    177

    Easyradio Probleme

    Anzeige

    Hallo,

    Ich wollte meine zwei Easyradios testen, die funktionieren aber irgendwie nicht richtig. Stromaufnahme bei 20mA und auf Kommandos kriege ich korrekte Antworten bei beiden (z.B. Firmwarestrings).
    Das Kommunizieren will allerdings nicht klappen. Beim Einen sende ich jede Sekunde 170 Bytes hintereinander in den Puffer, ich kann mit meinem Spannungsmessgerät Änderungen am Busyausgang messen.
    Beim anderen allerdings nicht und es kommt auch nichts beim seriellen Ausgang an (da wartet ein Microcontroller). Die Entfernung ist unter 1m. Irgendwelche Ideen warum das nicht funktionieren könnte?

  2. #2
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    05.05.2007
    Beiträge
    177
    Ich habe gesehen, das wenn ich den seriellen Eingang direkt mit dem Ausgang des µC verbinde fließen wirklich um die 20 mA mehr (also insgesamt 40mA, bei beiden so). Ich habe jetzt einen 1k Vorwiederstand dazwischengesetzt, und jetzt ist der Stromfluss bei 20mA wieder OK. Könnte das mit den Problemen was zu tun haben (Übertragung geht immer noch nicht)?

  3. #3
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    18.08.2004
    Ort
    bw-germany
    Alter
    39
    Beiträge
    272
    hast du alles richtig angeschlossen ?
    bei modul muss man einen pin entweder an GND oder VCC ziehen... (habe jetzt kein dattenblat zur hand)

  4. #4
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    05.05.2007
    Beiträge
    177
    Ich bekomme ja Kommandoantworten richtig zurück. (Kommando senden->Easyradio sendet antwort, nur Funken geht nicht)

  5. #5
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    18.08.2004
    Ort
    bw-germany
    Alter
    39
    Beiträge
    272
    да бля. открой даташит

    ER400TS-02.pdf :::
    PIN7 : Host Ready Input -- Digital Input to indicate that Host is Ready to receive serial data from transceiver

  6. #6
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    29.12.2005
    Ort
    Nähe Mainz
    Alter
    26
    Beiträge
    3.467
    Hast du daran gedacht, die Verbindungen zw. dem µC und dem ER zu kreuzen? Also RX nach TX und umgekehrt?

    Was aber zum einfacheren Fehlersuchen hilfreich ist, wäre ein Schaltplan und eventuell auch ein Programm.

    jon
    Nice to be back after two years
    www.roboterfreak.de

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •