-
        
+ Antworten
Ergebnis 1 bis 3 von 3

Thema: Motor Ansteuerung mit RN-Control

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    08.10.2004
    Beiträge
    11
    Hallo Frank,

    danke für die ausführlichen Antworten und für das Programm. Um die Zeit noch aktiv!!!
    Ich kann es übersetzen und zum RN-Control laden.

    Weiter hab ich mich noch nicht getraut. Ich denke ich muß RN-Control mit RN-Motor über RS232 verbinden, so dass es entsprechend funktioniert. Oder?

    Habe den Rat befolgt und ein wenig mit dem Bascom gespielt, indem ich das beiliegende Testprogramm (rncontrolmega32.bas) abgespeckt habe, so dass ich die Teile mit der Demo-Version des Compilers übersetzen und ins RN-Control laden konnte.

    1. Frage: Muß ich den ISP-Stecker jedesmal abziehen, wenn ich das übertragene Programm testen will?
    2. Frage: Muß ich dabei das Board ausschalten?
    3. Frage: Keiner der angeschlossenen Motoren dreht sich, obwohl ich die Kabel Vertauscht habe.
    Wie programmiere ich den Strom, ändere die Step-Rate, so dass das funktioniert. Daten für Motor 12V, 52 Ohm, Bi-Polar.
    Die Motoren produzieren so nur ein leises singen. Könntest du diesen Teil noch besser kommentieren?

    I = 0
    Do
    Pwm1a = I
    Pwm1b = I
    Waitms 80
    I = I + 5
    Loop Until I > 1023

    Wait 1
    Do
    Pwm1a = I
    Pwm1b = I
    Waitms 80
    I = I - 5
    Loop Until I < 1
    Pwm1a = 0 'Linker Motor aus
    Pwm1b = 0

    Beste Grüße,
    Udo

  2. #2
    Administrator Robotik Einstein Avatar von Frank
    Registriert seit
    30.10.2003
    Beiträge
    4.943
    Blog-Einträge
    1
    Hallo Udo,

    ich hab den letzten Beitrag mal hier her verschoben weil es ja doch mehr um Bascom und Getriebemotoren geht.

    In dem oberen Beispiel werden die beiden Motoren recht schnell beschleunigt und wieder abgebremst.
    Durch die Anweisung
    Pwm1a = i
    wird die Geschwindigkeit es einen Motors festgelegt. I kann einen Wert von 0 bis 1023 annehmen. 0 bedeutet Stillstand und 1023 ist vollgas!

    Mir Pwm1b = i wird das gleiche für den anderen Motor gemacht.
    Eigentlich sollte das problemlos klappen, falls du oben keine wichtige config Zeile weggekürzt hast.
    Das Netzteil sollte aber zumindest 500 mA und 9V bringen, Akkus sollten auch voll sein, versteht sich.
    Ein leises singen deutet darauf hin das die Spannung für den Motor nicht ausreicht.
    Du kannst oberen Programmabschnitt ganz weglassen und nur schreiben:
    Pwm1a = 1023I
    Pwm1b = 1023

    Dann sollten sich beide Motoren voll drehen!
    Sollte es nicht klappen, dann poste am besten mal dein zusammengekürzten Code komplett!

    Gruß Frank

  3. #3
    Administrator Robotik Einstein Avatar von Frank
    Registriert seit
    30.10.2003
    Beiträge
    4.943
    Blog-Einträge
    1
    Ach so, fast vergessen:

    Den ISP-Stecker kannst du in RN-Control immer stecken lassen, auch wenn Programm läuft. Und falls du ihn doch mal rausziehen willst, muss nicht unbedingt das Board ausgeschaltet werden.


    Und wenn du RN-Motor verbindest, dann must du nur die dreipoligen Stecker (RS232) verbinden. Ist nicht tragisch wenn du mal äußere PIN´s vertauschst, einfach umdrehen.

+ Antworten

Berechtigungen

  • Neue Themen erstellen: Ja
  • Themen beantworten: Ja
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •