-
        

Ergebnis 1 bis 3 von 3

Thema: Problem Portausgänge des 8051 im RESET auf High

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    26.01.2009
    Beiträge
    11

    Problem Portausgänge des 8051 im RESET auf High

    Anzeige

    Hallo zusammen,
    ich habe eine Frage zur Beschaltung von Ports des 8051-Controllers. Ich verwende den 89c51CC03 und will damit einen BTS (Highside-Switch) ansteuern. Der BTS wird eingeschaltet mit einem High-Pegel (High-Signal).
    Mein Problem ist, dass beim Einschalten des Controllerboards (Controller ist zuerst im Reset) der BTS kurz eingeschaltet wird, weil im Reset-Zustand der Controller an den Ausgängen einen High-Pegel hat. Verursacht wird dies durch den internen PullUp des Controllers.
    Welche Lösungen gibt es dafür?
    Reicht eine Negierung durch eine Transistorschaltung aus?
    Oder ist es besser das ganze mit TTL-Bausteinen (7400) zu lösen?
    Gibt es Logikbausteine die sehr wenig Strom ziehen die ich dafür verwenden kann?

    Gruß Klaus

  2. #2
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    21.06.2008
    Beiträge
    113
    Du hast doch in einem anderen Forum bereits die lösung bekommen [-X

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    26.01.2009
    Beiträge
    11
    Ist es verboten hier Fragen zu stellen, oder was soll dieser blöde Kommentar?
    Da kann man sich doch wieder nur mal aufregen, wegen einem "Bauteiltöter". [-X
    Du bist doch auch in mehreren Foren, oder nicht?
    Also, bleib ruhig!

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •