-         

Ergebnis 1 bis 5 von 5

Thema: 2 Spannungsregler Board - 5 und 9 volt

  1. #1

    2 Spannungsregler Board - 5 und 9 volt

    Anzeige

    Hallo zusammen,

    für unseren Roboter brauchen wir 2 verschiedene Spannungen.
    5 Volt für Atmega32 und Abstandssensoren. 9 Volt für die Motoren.
    Das Motorboard besteht aus einem L298. Die 2 Motoren sind Modelcraft RB350. Ziehen jeweils laut Datenblatt nur 300mA.

    Ich habe mir aus verschiedenen Schaltungen, die ich im Netz gefunden habe, was zusammengestrickt. Leider bin ich kein Elektroniker und ich bräuchte mal eure Hilfe, ob die Schaltung für unseren Bot geeignet ist. (Oder überhaupt was taugt?!)



    Danke

    red23

  2. #2
    Erfahrener Benutzer Roboter Experte Avatar von Tido
    Registriert seit
    14.11.2006
    Ort
    OWL
    Alter
    41
    Beiträge
    609
    Moin,

    generell sollte das so (elektrisch gesehen) funktionieren.

    Trotzdem würde ich es etwas anders aufbauen, wenn ihr nur 12V als Eingangsspannung wählt:

    Die Eingangsspannung von 12V fällt an der Verpolschutzdiode D1 um ca. 0,7V ab, es bleiben also 11,3V. Am Motortreiber L298 fallen m.W. später auch ca. 2V (Datenblatt beachteb) ab, so dass für die Motoren auch ohne Spannungsregler ca. 9,3V übrig bleiben. Ich würde aus diesem Grund auf den Spannungsregler für die Motoren verzichten (werden die Motoren später per PWM betrieben, so kann sowieso per Software der max. Spannungswert für die Motoren gewählt werden).

    Desweiteren würde ich Schaltungen mindestens auf Lochrasterplatinen erstellen, man kann so eine Menge Platz sparen, dafür müssen dann eben Leiterbahnen per Draht gezogen werden.
    MfG
    Tido

    ---------------------------------------------------
    Have you tried turning it off and on again???
    ---------------------------------------------------

  3. #3
    danke für die antwort..

    ja die motoren werden per PWM betrieben.

    Kann es denn nicht ohne spannungsregler passieren,
    daß die Motoren die Spannung in den Keller ziehen können und der Atmega resettet wird?

    Und noch eine Frage zu C1. Ich habe gelesen, daß man pro 1mA 1uF für den Kondensator planen soll.
    Kann ich also wirklich nur 1 Ampere bedienen mit dem Board?

    Grüße

    red23

  4. #4
    Erfahrener Benutzer Roboter Experte Avatar von Tido
    Registriert seit
    14.11.2006
    Ort
    OWL
    Alter
    41
    Beiträge
    609
    Hallo.

    Zitat Zitat von red23
    Kann es denn nicht ohne spannungsregler passieren,
    daß die Motoren die Spannung in den Keller ziehen können und der Atmega resettet wird?
    Da auf dem Weg zum 5V-Spannungsregler nur zwei Widerstände (Leitungswiderstand und Innenwiderstand der Spannungsquelle) liegen kann auch nur eine Spannung an diesen abfallen. Soll heißen, dass wenn die Spannung zusammenbrechen sollte die Spannungsquelle (Akku/Netzteil) ungeeignet ist. Ein zusätzlicher Spannungsregler für die Motoren ändert daran nichts.

    Zitat Zitat von red23
    Und noch eine Frage zu C1. Ich habe gelesen, daß man pro 1mA 1uF für den Kondensator planen soll.
    Kann ich also wirklich nur 1 Ampere bedienen mit dem Board?
    Wird das ganze mit einem Netzteil betriebn, so hängt die max. Belastung von diesem und den darin befindlichen Kondensatoren ab. Bei Akkubetrieb dient der Kondensator "nur" zum Puffern/Abfangen von Lastspitzen.
    MfG
    Tido

    ---------------------------------------------------
    Have you tried turning it off and on again???
    ---------------------------------------------------

  5. #5
    Neuer Benutzer Öfters hier
    Registriert seit
    26.11.2008
    Beiträge
    13
    die Faustregel 1µF Lade-/Glättungskapazität pro 1mA Laststrom ist m.E. bei Grätzgleichrichtung gültig.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •