-
        

Ergebnis 1 bis 8 von 8

Thema: Gerade Fahrt mit GoTurn funktioniert nicht

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    08.05.2008
    Ort
    Passau
    Alter
    25
    Beiträge
    18

    Gerade Fahrt mit GoTurn funktioniert nicht

    Anzeige

    Hi @ all!

    Ich hab zu Weihnachten einen Asuro bekommen und es hat bisher auch alles funktioniert.

    Mein Problem ist, dass ich es mit der GoTurn Funktion nicht schaffe, dass er gerade aus fährt. So müsste es doch gehen:
    Code:
    GoTurn(20,0,150);
    Er fährt aber nur Rechtskurven

    Hier der komplette Code:
    Code:
    #include "asuro.h"
    
    int main()
    {
    	Init();
    	while(1)
    	{
    		GoTurn(20,0,150);
    	}
    	return 0;
    }
    Was mache ich falsch?

  2. #2
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    29.05.2005
    Beiträge
    1.018
    Hallo robrunner,

    die Funktion GoTurn(), bzw. die beiden Macros Go() und Turn(), nutzen aus der Asuro-LIB die Interruptfunktion zum lesen der Odometrie-Daten.
    Um hier vernünftige Werte zu erhalten müssen einige Defines in der Datei myasuro.h an deinen Asuro angepasst werden.

    Am einfachsten geht es mit dem Programm hier. (Der Link zum downloaden geht nun auch wieder.)

    Frohes Neues Jahr wünscht
    Sternthaler
    Lieber Asuro programieren als arbeiten gehen.

  3. #3
    Erfahrener Benutzer Roboter Genie Avatar von m.a.r.v.i.n
    Registriert seit
    24.07.2005
    Ort
    Berlin
    Beiträge
    1.247
    Hallo robrunner,

    der Aufruf von EncoderInit() fehlt.

  4. #4
    Neuer Benutzer Öfters hier
    Registriert seit
    08.05.2008
    Ort
    Passau
    Alter
    25
    Beiträge
    18
    OK danke so gehts

    Tolles Prog Sternthaler!

    Auch ein frohes neues jahr meinerseits!

  5. #5
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    29.05.2005
    Beiträge
    1.018
    Oh Mist, oh Mist, oh Mist,

    m.a.r.v.i.n hat natürlich wieder einmal Recht mit dem EncoderInit().
    Ob ich da ein tolles Programm gemacht habe, wird sich erst noch herrausstellen, wenn du robrunner mal postest wie groß die Unterschiede der Defines aus der Lib und den Werten aus dem Porgramm sind. Möglicherweise würde es schon ohne Anpassungen gehen.

    Und? Schon alle Knaller explodiert und nun weiter am Asuro?
    Ich leere gerade noch die Reste mit den wieder eintrudelnden 'Kindern' und bin dann auf dem Weg in die Heia.

    Auf das neue Jahr
    Sternthaler
    Lieber Asuro programieren als arbeiten gehen.

  6. #6
    Neuer Benutzer Öfters hier
    Registriert seit
    08.05.2008
    Ort
    Passau
    Alter
    25
    Beiträge
    18
    Man braucht beides:

    Ohne deine Werte, Sternthaler, trotz EncoderInit(), fährt er immer noch genauso im Kreis, wie vorher.
    Mit deinen Werten, aber ohne EncoderInit() fährt er nur noch leicht schief.
    Mit deinen Werten und EncoderInit() fährt er fast perfekt gerade.

    Eine Frage hätte ich noch:
    In asuro.h steht als Kommentar beim Funktionsprototypen für GoTurn:
    \param distance travalling distance in cm.
    Ich muss aber für 20cm Fahrt nicht 20 als Parameter eingeben, sondern 200.
    An sich ist das natürlich kein Problem, ich wollte bloß wissen, ob das normal ist.

    Und? Schon alle Knaller explodiert und nun weiter am Asuro?
    Sicher doch

  7. #7
    Neuer Benutzer Öfters hier
    Registriert seit
    29.11.2008
    Beiträge
    7
    Hast du schon die Odometrie Modofikation aus dem Wiki gemacht? Sprich keine Häuschen aus schwarzem Fotokarton über die Sensoren gebaut? Mit denen funktioniert es hier super.
    Bilder zu den Häuschen findest du im Wiki.

  8. #8
    Neuer Benutzer Öfters hier
    Registriert seit
    08.05.2008
    Ort
    Passau
    Alter
    25
    Beiträge
    18
    OK werd ich dann morgen machen.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •