-         

Ergebnis 1 bis 7 von 7

Thema: WinAvr findet Atmega32 nicht

  1. #1
    Benutzer Stammmitglied
    Registriert seit
    09.09.2004
    Ort
    BitteKeinePrivatenDatenAngeben! Danke!
    Beiträge
    63

    WinAvr findet Atmega32 nicht

    Anzeige

    Hallo zusammen

    Ich habe ein Problem mit meinem Atmega32.

    Wenn ich den Microcontroller programmieren will, dann kommt folgende
    Meldung:

    (Code in Bascom compiliert (NONAME1.HEX) und mit Avrdude "rübergeladen")


    [php:1:cc8f4f12fe]

    C:\Program Files\WinAvr\bin>avrdude -p m32 -c usbasp -C "avrdude.conf" -U flash:
    w:"NONAME1.HEX":i
    found 8 busses

    avrdude: error: programm enable: target doesn't answer. 1
    avrdude: AVR device initialized and ready to accept instructions

    Reading | ################################################## | 100% 0.01s

    avrdude: Device signature = 0xffffff
    avrdude: Yikes! Invalid device signature.
    Double check connections and try again, or use -F to override
    this check.


    avrdude done. Thank you.

    [/php:1:cc8f4f12fe]

    Der Treiber für den USBAsp ist installiert.

    Könnt ihr mir da weiterhelfen?
    Ich hoffe ich habe alles notwendige erwähnt, wenn nicht sorry bin nicht neu in AVR ^^!

    Gruss Bugmenot

  2. #2
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    08.07.2004
    Ort
    Südhessen
    Beiträge
    1.312
    Das weist auf einen Schaltungsfehler hin.
    Wenn er keine Verbindung hätte, würde er Dir das sagen. Aber er hat eine Verbindung und liest die falsche Signatur. Das klingt ganz danach, als bilde sich der Programmer eine funktionierende Verbindung bloß ein und liest dann eben "in der Luft", so dass immer 1en rauskommen.

    Mach das, was da steht: Double check connections. Ich selbst saß mal über zwei Wochen an einer fast unsichtbaren Lötbrücke unter einem SMD-Widerstand.

  3. #3
    Benutzer Stammmitglied
    Registriert seit
    09.09.2004
    Ort
    BitteKeinePrivatenDatenAngeben! Danke!
    Beiträge
    63
    Danke für deine Antwort!

    Ich habe nun erfolgreich ein Programm mit einem Linux und Avrdude über einen Parallelport rübergeladen und es konnte auch ausgeführt werden!

    Nun habe ich aber mit dem USB Programmer (USBASP) unter Windows das Problem, dass der Programmer kurz blinkt, wenn ich bei Bascom auf "Program Chip" klicke. Der Atmega resetet anscheinend aber programmiert wird nichts, es wird weiterhin das alte Programm (dass ich noch mit Linux rübergeladen habe) ausgeführt! Das Programm wurde vorher schon compiliert!

    Der Programmer ist Avrdude, ich habe folgende Parameter eingegeben:

    -c usbasp -p m32 -C "C:\Program Files\WinAvr\bin\avrdude.conf" -U flash:w:"{file}":i

    Könnt ihr mir da weiterhelfen?

    Gruss bugmenot

  4. #4
    Gut, das würde ja schon mal heissen, dass die Schaltung funktioniert

    Bist du sicher dass du die richtigen Treiber installiert hast?
    Und falls du Vista hast, sind die auch für Vista geeignet?

    Schönen Feierabend

  5. #5
    Benutzer Stammmitglied
    Registriert seit
    09.09.2004
    Ort
    BitteKeinePrivatenDatenAngeben! Danke!
    Beiträge
    63
    Ja der Treiber sollte richtig installiert sein, da ich im Geräte Manager "USBasp" sehen kann.

  6. #6
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    15.11.2004
    Ort
    Aachen
    Alter
    32
    Beiträge
    246
    Wird das Target mit Strom versorgt?
    Wenn nicht, dann (und nur dann) am USBasp den Schalter/Jumper zur Versorgung des Targets setzen.

    Welche Taktrate ist auf dem Chip eingestellt?
    Wenn der noch mit 1MHz rumdümpelt, dann musst du am USBasp den Schalter/Jumper "SlowSCK" aktivieren, da der Chip sonst nicht mit kommt!

    Gruß,
    Thomas

  7. #7
    Benutzer Stammmitglied
    Registriert seit
    09.09.2004
    Ort
    BitteKeinePrivatenDatenAngeben! Danke!
    Beiträge
    63
    Habe jetzt beim USB Programmer den DIP 5 auf ON gstellt und nun gehts!

    Danke für eure Hilfe!

    mfg bugmenot

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •