-
        

Seite 196 von 355 ErsteErste ... 96146186194195196197198206246296 ... LetzteLetzte
Ergebnis 1.951 bis 1.960 von 3542

Thema: Willas Shrediquette Tricopter / Quadrocopter / Hexacopter

  1. #1951
    Erfahrener Benutzer Roboter Genie Avatar von Bammel
    Registriert seit
    11.12.2004
    Ort
    Bremen
    Alter
    29
    Beiträge
    1.400
    Anzeige

    Zitat Zitat von jevermeister Beitrag anzeigen
    Bammel: Ist der Wiki so besser? Ich mache mehr von Hand jetzt, man beachte das Get Started Tutorial.
    Wo hat sich da den was verändert?
    Ich fände das schön wie hier im RN-Wissen in der mitte ein willkommenstext oder sowas in der art und an der seite so menüpunkte.
    oder wo finde ich einen index? wenn man auf get started klickt und dann ganz unten, nur sowas sollte einfacher und auf der startseite zu finden sein.

    deutsche texte kann ich dir gerne liefern! kann man dann ja auch beide mit im Wiki lassen.
    hab grade am wochenende gemerkt das mein englisch nicht das beste ist. verstrehen tue ich es zwar ganz gut aber selber sprechen... naja.

    Zitat Zitat von jevermeister Beitrag anzeigen
    Zum Thema Pan/Tilt Ausgleich: Ich habe gestern die ersten Hardwaretestet mit der Elektronik gemacht und es macht einen vielversprechenden Eindruck, ich habe zur Zeit eine externe 5V Versorgung, da mir ein entsprechender Kondensator fehlt um von 12V auf 5V zu gehen. Aber prinzipiell funktioniert der Ausgleich sehr gut. Ich musss jetzt mal schauen wie sich das aufs bild auswirkt, evtl muss das Signal noch geglättet werden.
    Wie hast du den nun den code ausgelegt? hast mal die passage da?

    Zitat Zitat von jevermeister Beitrag anzeigen
    ps.: Ich habe übrigens eidnrucksvoll gezeigt bekommen, wie ein Tricopter ohne Gyros fliegt, nämlich garnnicht, mir sit die MAsseleitung zu den Gyros abgebrochen, AUA!! Gottseidank war das nicht beim 200m Flug mit Kamera sondern beim Starten direkt danach.
    genau das phänomen hatte ich auch schon. im recht schnellen vorwärtsflug in ca 5 metern höhe. sieht sehr lustig aus




    bei mir tut sich erstmal wohl nichts finanziel ists momentan sehr schlecht udn die motoren die ich haben möchte sind nicht auf lager und es ist nicht bekannt wann diese wieder da sind.
    aber ich habe momentan noch zwei andere Projekte am laufen. eins ist garnet so copterfremd

  2. #1952
    Erfahrener Benutzer Roboter-Spezialist Avatar von jevermeister
    Registriert seit
    20.01.2011
    Ort
    Kiel
    Beiträge
    393
    So, sorry das war meine persönliche Einstellung, ich habs noch versucht zu optimiere. So jetzt besser?

    Gruß
    Nils

  3. #1953
    Erfahrener Benutzer Roboter Genie Avatar von Willa
    Registriert seit
    26.10.2006
    Ort
    Bremen
    Alter
    36
    Beiträge
    1.267
    Hi,
    ein kleines video von meinem BOLT ist fertig:



    Außerdem ein paar mehr bilder auf:
    http://shrediquette.blogspot.com/p/s...ette-bolt.html
    Viele Grüße, William
    -> http://william.thielicke.org/

  4. #1954
    Erfahrener Benutzer Fleißiges Mitglied Avatar von Amigorodrigo
    Registriert seit
    02.11.2010
    Ort
    Köln
    Beiträge
    124
    Nabend!

    hey willa - hab heute morgen schon deinen neuen bolt-clip gesehen.
    sehr geiles video mal wieder. auch wenn die mukke ganz schön crazy ist

    sieht total geil aus wie der winzling auf einen zufliegt - erst ist er gar nicht zu sehen - und dann surrt er plötzlich an einem vorbei. (ab Minute 2)

    der flug quer durch die bude ist ein klassischer willa . hab ich noch nirgends sonst gesehen.
    da kann die IMAV ja kommen (ring aufnehmen klappt ja auch :P) - wobei der bolt auch dicke durch den kamin passen würde!
    Gruß
    Amigo

  5. #1955
    Erfahrener Benutzer Roboter-Spezialist Avatar von jevermeister
    Registriert seit
    20.01.2011
    Ort
    Kiel
    Beiträge
    393
    Hi,
    geilles Video Willa, die wohnungsnummer traue ich mich auch, sobaldich größere Räume habe

    Amigo, ich weiss garnicht was Du hast, Willa hat auch Moby schon wieder zurück auf meinen MP3 Player geholt mit seinem letzten Video .

    @All:
    Pan und tilt funktioniert jetzt, der Erstflug kommt morgen, da ich gleich zum Sport muss:

    Folgenden Code habe ich implementiert:
    Code:
    If Portb.2 = 0 Then
    
    
    '(
    'möglichkeit 2 über PID korrekturwerte servo wird am anfang initialisiert und es werden jeweils die abweichungen hinzugerechnet
    
    
      Servo_pan_pidd = Servo_pan_pidd + P_set_roll_int
      Servo_pan_pidd = Servo_pan_pidd + I_set_roll_int
      Servo_pan_pidd = Servo_pan_pidd + D_set_roll_int
      Servo_pan_pidd = Servo_pan_pidd + Dd_set_roll_int
      Servo_pan_pidd = Servo_pan_pidd / 21540
      Servo_pan_pidd = Dd_set_roll_int * 1000
      Servo_pan_pidd = Dd_set_roll_int + 32535
    
     'Klappt aus irgend einem Grund nicht, der servo driftet sofort ab ->überdenken
    ')
    
      Servo_pan = Meas_angle_roll / 21540                       'divide by value for 1g
      Servo_pan = Servo_pan * 1000                              'multiply with 1000 to get the servo format
      Servo_pan = Servo_pan + 32535                             'Mittelstellung addieren
      If Servo_pan > 33534 Then                                 'Overflow Protection
       Servo_pan = 33534
       End If
       If Servo_pan < 31536 Then                                'Overflow Protection
        Servo_pan = 31536
       End If
        Servo_pan = Servo_pan + 30000                           'add the remaining 30000 for neutral position
       If Camservo_bo = 1 Then
        Servo_pan_pwm = Servo_tilt
       Else
        Servo_pan_pwm = 62535                                   'center Position
       End If
    End If
    
    If Portb.3 = 0 Then
      Servo_tilt = Meas_angle_nick / 21540                      'divide by value for 1g
      Servo_tilt = Servo_tilt * 1000                            'multiply with 1000 to get the servo format  #
      'Wenn ich selber noch kippen will, dann muss ich hierzu noch die werte meines Potis auf Kanal 6 Adden
    '(
       Manual_tilt = Empf(6) / Endwert                          'Poti auslesen und auf verhältnis umrechnen
       Manual_tilt = Manual_tilt * 1000                         'Auf Servowerte skalieren
      Servo_tilt = Servo_tilt + Manual_tilt                     'zum Tiltausgleich addieren/subtrahieren
    
    ')
      Servo_tilt = Servo_tilt + 32535                           'Mittelstellung addieren
      If Servo_tilt > 33534 Then                                'Overflow Protection
       Servo_tilt = 33534
       End If
       If Servo_tilt < 31536 Then                               'Overflow Protection
        Servo_tilt = 31536
       End If
        Servo_tilt = Servo_tilt + 30000                         'add the remaining 30000 for neutral position
       If Camservo_bo = 1 Then
        Servo_tilt_pwm = Servo_tilt
       Else
        Servo_tilt_pwm = 62535                                  'center Position
       End If
    
    End If
    und

    Code:
    Servoirq:                                                   'generate servo PWM pulse
    If Servo_nr_by = 0 Then
       If Portd.6 = 0 Then                                      'wenn port low
          Timer1 = Servopwm                                     'dann timer auf entsprechende verzögerung
          Portd.6 = 1                                           'und port anschalten
       Else                                                     'das hier passiert erst bei dem darauf folgenden interrupt
          Portd.6 = 0                                           'dann port wieder ausschalten
          Incr Servo_nr_by                                      'und den nächsten kanal bearbeiten
       End If
    End If
    If Servo_nr_by = 1 Then
       If Portb.2 = 0 Then
          Timer1 = Servo_pan_pwm
          Portb.2 = 1
       Else
          Portb.2 = 0
          Incr Servo_nr_by
       End If
    End If
    If Servo_nr_by = 2 Then
       If Portb.3 = 0 Then
          Timer1 = Servo_tilt_pwm
          Portb.3 = 1
       Else
          Portb.3 = 0
          Incr Servo_nr_by
       End If
    End If
    
    If Servo_nr_by = 3 Then
      Timer1 = 40000                                            'eine pause von ca. 12ms bis zum nächsten interrupt. Bei guten Servos oder Brushlessreglern kann man hier bis auf 65530 gehen ==> ansteuerfrequenz von ~ 200Hz
      Servo_nr_by = 0
    End If
    
    Return
    Das zweite Codestück ist von Willa's Artikel im RN Wissen übernommen (Willa, wie sollte ichd a die Zeit für Timer1 einstellen, bin mir da mit 40000 nicht sicher)

    Im Trockendock geht das schon ganz gut, mir fehlt nur noch die Mechanik für den Kamerarm..



    Diese Schaltung entstand mit Hilfe von Ssellere, der mir die Lösung mit dem Spannungswandler erklärt hat.

    Gruß
    Nils
    ps.: den fertigen Code gibts dann im Blog


    Die elektronik ist auch fertig,
    sollte sichd as bewähren, wird das natürlich noch aufgehübscht

  6. #1956
    Erfahrener Benutzer Fleißiges Mitglied Avatar von Amigorodrigo
    Registriert seit
    02.11.2010
    Ort
    Köln
    Beiträge
    124
    Zitat Zitat von jevermeister Beitrag anzeigen
    ...

    Amigo, ich weiss garnicht was Du hast, Willa hat auch Moby schon wieder zurück auf meinen MP3 Player geholt mit seinem letzten Video .

    ...
    jau und vivaldi

    edit: hätte ich eigentlich auch ohne shazam wissen müssen, dass das "the knife" ist - hab ich irgendwann mal auf vimeo gehört, als willa das "geliked" hat
    für mich halt ne spur zu abgefahren 8-)
    Gruß
    Amigo

  7. #1957
    Erfahrener Benutzer Roboter Genie Avatar von Bammel
    Registriert seit
    11.12.2004
    Ort
    Bremen
    Alter
    29
    Beiträge
    1.400
    Hey Wiliam,

    klasse video! und schicke wohnung ideal zum durchfliegen... ist dein bolt nun schneller geworden oder täuscht das im video?
    mich würde nun noch interesieren was der brummer wiegt?

    wie heist der musik-track? ich find den wahnsinnig geil
    EDIT: gefunden... the knife ist ja mal richtig geil

    @nils.. ich bin weiterhin auch videos gespannt.
    Geändert von Bammel (11.05.2011 um 22:54 Uhr)

  8. #1958
    Erfahrener Benutzer Roboter-Spezialist Avatar von jevermeister
    Registriert seit
    20.01.2011
    Ort
    Kiel
    Beiträge
    393
    Moin,
    so erstflug mit Nick/roll Ausgleich hat geklappt und war so semi-erfolgreich...

    Also prinzipiell geht das, aber der servo zittert in eine Richtung wie verrückt, ich weiss nicht ob das an der Mechanik liegt (ich habe eben schnellw as zusammengefrickelt, da ich noch auf meinen neuen Arm vom Kumpel warte) oder ob da ein Problem mit der Lageerkennung ist.
    Onboard sieht das schon echt gut aus,w enn das Zittern nicht wäre, ich kann den Tri voll schräg stellen und das Bild bleibt gerade, man merkt es nur am, Prop der mal oben und mal unten im Bild ist

    Ich habe mal ein Video gemacht, vielleicht seht ihr da gleich was:



    Gruß
    Nils

  9. #1959
    Erfahrener Benutzer Roboter-Spezialist Avatar von deHarry
    Registriert seit
    17.08.2010
    Beiträge
    597
    Zitat Zitat von jevermeister Beitrag anzeigen
    Also prinzipiell geht das, aber der servo zittert in eine Richtung wie verrückt, ich weiss nicht ob das an der Mechanik liegt ...

    Ich habe mal ein Video gemacht, vielleicht seht ihr da gleich was:
    Hi Nils,
    sieht für mich aus, als würde der Kasten für die Cam den kompletten Tri ins Schwingen bringen, was der IMU aufnimmt und versucht zu kompensieren.
    Wenn dann durch die Hebelei für den Antrieb noch Spiel im Spiel ist (huch, fast ein Wortspiel ) schwingt sich das schön auf.
    Einen ähnlichen Effekt hatte ich anfangs mit meiner Heckausleger-Drehmechanik. Ist erst deutlich besser geworden, als ich das Spiel beseitigt und die Drehachse in den Massenschwerpunkt des Motors gelegt hatte.
    Den Schwerpunkt wirst du bei der Kamerahalterung außen vor lassen müssen, denke ich, da du zwei Freiheitsgrade berücksichtigen musst.
    Gruß
    Harald
    __________________
    Modellbau&Elektronik
    www.harald-sattler.de

  10. #1960
    Erfahrener Benutzer Roboter-Spezialist Avatar von jevermeister
    Registriert seit
    20.01.2011
    Ort
    Kiel
    Beiträge
    393
    Hallo Harry,
    danke für die Antwort. Ich kann aber ein Vibrationsproblem ausschliessen, ich habe heute das ganze mal probiert, indem ich den Servo direkt an den Empfänger angeschlossen habe, da ist das gleiche Verhalten zu sehen. Daraufhin habe ich den Drehpunkt in die Mitte gesetzt und die Umlenkung geändert indem ich den Servo anders plaziert habe. Auch das hat nichts gebracht.
    Offenbar ist die interne Regelung des Servos das Problem...

    Gibt es für sowas spezielle Servos oder was benutzen die Leute so für den Cam ausgleich?

    Gruß
    Nils

Seite 196 von 355 ErsteErste ... 96146186194195196197198206246296 ... LetzteLetzte

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •