-         

Ergebnis 1 bis 3 von 3

Thema: avr studio- time overflow interrupt simulieren - PROBLEM!

  1. #1

    avr studio- time overflow interrupt simulieren - PROBLEM!

    Anzeige

    Hallo Zusammen

    Ich versuche gerade den Einstieg in die AVR Welt zu schaffen
    Dieser ist aber so ziemlich schwer

    Habe gerade verscuht dieses (http://www.roboternetz.de/wissen/ind...r-Abfrage_in_C) Beispiel im AVR Studio zum laufen zu bringen.

    Zum Teil gelingt mir das auch. Aber meine Interrupt-Rutine tritt nie auf!
    D.h. auch wenn ich ein Breakpoint in "SIGNAL (SIG_OVERFLOW0)" hinzufüge, wird der Programmablauf nie in diesem Interrupt einsteigen.

    Was habe ich da vergessen einzustellen? Was mache ich falsch?

    Danke für die Hilfe

  2. #2
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    25.11.2003
    Beiträge
    1.111
    Kann es sein, dass Dein ungenannter Compiler mit diesen alten Definitionen der ISRs nichts anfangen kann?
    Die neue heißt:
    ISR (TIMER0_OVF_vect){
    }
    Ansonsten solltest Du mal Deinen Code posten, wie soll denn sonst jemand den Fehler finden????

  3. #3
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    20.05.2006
    Ort
    Lippe
    Alter
    48
    Beiträge
    524
    Hallo,

    schreib doch bitte etwas genauer, was du wie machst. Läuft das Programm im Simulator überhaupt? Kannst du dir den Zählerstand des Timers0 anschauen? Hast du den richtigen Controller für die Simulation eingestellt? usw, usw.
    Was für eine Version hast du?

    Gruß

    Jens

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •