-
        

Ergebnis 1 bis 5 von 5

Thema: LPT kein Spannungsanstieg messbar!

  1. #1

    LPT kein Spannungsanstieg messbar!

    Anzeige

    Hallo,
    bin ziemlich neu hier. Also mein Problem ist, wie es der Titel schon sagt, dass ich keinen Spannungsanstieg am LPT messen kann.
    Ich habs mit Inpout32.dll versucht, konnte softwaretechnisch auch keine Mängel feststellen, aber wenn ich 0xff ausgebe, kann ich mit meinem Multimeter nichts messen.
    Hoffe ihr könnt mir helfen! [-o<
    mfg

  2. #2
    Benutzer Stammmitglied
    Registriert seit
    16.12.2007
    Beiträge
    39
    hast du zwischen den richtigen pins gemessen?
    also z.B. pin 2 (bit 0) und 18-25 (Masse)?
    versuch mal nem lpt tester programm die pins anzusteuern.
    funzt ein gekauftes gerät an dem port (z.B. n lpt drucker)?

    Ele

  3. #3
    Erfahrener Benutzer Fleißiges Mitglied Avatar von MarsoTexx
    Registriert seit
    24.11.2006
    Ort
    Lobith (Elten-Emmerich DE)
    Alter
    42
    Beiträge
    163
    Mit deinen Software und/oder Inpout.dll bin ich nicht bekannt.

    Aber, um sachen einfach zu machen, kannst du einen Tets-Konnector machen. Nimm einfach 8 LED's mit jeden ein 1kOhm Wiederstand zu Masse.

    Komt d'rauf an wie mann ansteurst, wenn nurr einmal ein Bit positief und wieder negatief machst, seht mann dass einfach nicht weil der Zeit der dem LED 'an' ist, viel zu Kurz ist. Wen mann z.B. langere Zeit (einiger Sekunden) den Bit positief last oder langere Zeit AN-AUS-AN-AUS schaltest, musst das sichtbar sein.

    Wie oft die Bits der LPT wechslen konnen pro Sekunde weiz ich nicht genau aber sowieso Zehntauzenden mall pro Sekunden!
    \/ To DIY or not to DIY
    www.europakade.nl

  4. #4
    Erfahrener Benutzer Lebende Robotik Legende Avatar von PICture
    Registriert seit
    10.10.2005
    Ort
    Freyung bei Passau in Bayern
    Alter
    66
    Beiträge
    10.970
    Hallo!

    @ Carrbit

    Einige LPTs benötigen pull-ups (um 4,7k), weil sie "open collector" Ausgänge haben.

    MfG

  5. #5
    Danke erstmal für die antworten! ich habe es versucht mit
    while(!kbhit())
    {
    (oup32)(0x378, 0xff);
    }
    So konnte ich keinen unterschied feststellen. Sollte ich es mit nur einem output versuchen. Aber so wie ihr sagt, wechselt der lpt ziemlich schnell. Nur wie kann man das umstellen?

    mfg

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •