-
        

Ergebnis 1 bis 5 von 5

Thema: RN-Control + 16*4A LCD

  1. #1
    Benutzer Stammmitglied
    Registriert seit
    21.03.2008
    Beiträge
    88

    RN-Control + 16*4A LCD

    Anzeige

    Hallo, hab heute ein LCD über den Wannenstecker an PortD angeschlossen.



    Wenn ich jetz Spannung auf meine RN-Control geb seh ich nur schwarze kästchen, ich komm echt nich weiter..


    hier mein Programm:
    Code:
     $regfile = "m8def.dat"
     $crystal = 4000000
    
     Config Lcd = 16 * 4
     Config Lcdpin = Pin , Db4 = Portd.0 , Db5 = Portd.1 , Db6 = Portd.2 , Db7 = Portd.3 , E = Portd.5 , Rs = Portd.4
     Config Lcdbus = 4
     
     Cls
     Locate 1 , 1
     Lcd "Hallo Welt"

  2. #2
    Benutzer Stammmitglied
    Registriert seit
    21.03.2008
    Beiträge
    88
    niemand?

    muss doch jemand sagen können wie ich das lcd richtig anklemm?

    hier die pdf, vom lcdhttp://www.reichelt.de/?;ACTION=7;LA...fce0d3b290a5b4

  3. #3
    Benutzer Stammmitglied Avatar von Tomizz
    Registriert seit
    09.09.2005
    Ort
    SK
    Beiträge
    34
    Hallo,

    ich krieg' mein Display auch nicht zum Laufen. Außer einem angezeigten Balken tut sich nichts. Aber das wird Dir auch nicht weiterhelfen.
    Ich bin mir nicht sicher, ob die Schaltung auch wirklich richtig ist. Es wird hier folgende Belegung am Mini Display Stecker angegeben:

    DB7 - Pin 1
    DB6 - Pin 2
    DB5 - Pin 3
    DB4 - Pin 4

    Aus dem AVR-GCC-Tutorial geht aber hervor, dass

    Pin 11 (LCD) = DB4 = PD0 am AVR (und damit Pin 1)
    Pin 12 (LCD) = DB5 = PD1 am AVR (und damit Pin 2)
    Pin 13 (LCD) = DB6 = PD2 am AVR (und damit Pin 3)
    Pin 14 (LCD) = DB7 = PD3 am AVR (und damit Pin 4)

    sein soll. Also genau anders herum. Was ist denn nun richtig? Das Display müsste bei einer falschen Belegung zwar auch was anzeigen, wenn auch nicht das, was man wollte. Ich habe die Belegung auf meinem (selbstgebastelten) LCD-Adapter entsprechend geändert, aber genützt hat's nicht.
    Ich habe so ziemlich alle verfügbaren Testprogramme ausprobiert (auch das von P. Fleury, nach entsprechender Anpassung an mein LCD), die ja angeblich so "totsicher" funktionieren sollen. Aber nichts tut sich. Ich hoffe, dass ich den Soft- oder auch Hardwarefehler irgendwann ausfindig machen kann.

    Ciao

  4. #4
    Benutzer Stammmitglied
    Registriert seit
    21.03.2008
    Beiträge
    88
    hallo,
    mein display läuft jetzt hatte ne kalte lötstelle am wannenstecker..

    jetz hab ich aber auch ein neues Problem, die Displaybeleuchtung funktioniert einfach nicht wenn ich eine Spannung auf Pin 16/15 Geb tuht sich nichts..

    gruß aphex

  5. #5
    Erfahrener Benutzer Robotik Einstein Avatar von Andree-HB
    Registriert seit
    10.12.2004
    Ort
    Bremen
    Alter
    47
    Beiträge
    2.556
    wenn ich eine Spannung auf Pin 16/15 Geb
    ...und warum nicht auf 17/18, wenn Dein Plan so stimmt ?
    Danke an Alle, die uns bei der erfolgreichen 1.000€-Aktion der IngDiba unterstützt haben! | https://www.hackerspace-bremen.de | http://www.pixelklecks.de |

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •