-
        

Ergebnis 1 bis 5 von 5

Thema: ? Stromversorgung von Servos

  1. #1

    ? Stromversorgung von Servos

    Anzeige

    SMARTPHONES & TABLETS-bis zu 77% RABATT-Kostenlose Lieferung-Aktuell | Cool | Unentbehrlich
    Hallo,
    mein Hobby sind nicht Roboter und Elektronik sondern die Modelleisenbahn, bei der ich Servos zum Steuern von Signalen und Weichen verwenden will. Beim Googlen bin ich durch den Suchbegriff „Servoansteuerung“ auf dieses Forum gestoßen und hoffe nun auf Eure freundliche Hilfe bei der Lösung eines Problems, zu dem ich bisher keine Lösungsansätze finden konnte.
    Nach der Beschaffung der entsprechenden Informationen habe ich eine Ansteuerung mit einem NE555 für Servos zur Weichensteuerung gebaut. Sie funktioniert einwandfrei; eine Weiche/ein Signal lässt sich durch Betätigung eines Schalters langsam umschalten.
    Nun macht die Stromversorgung der Servos Schwierigkeiten. Ich habe 10 Servos an eine 5V-Spannungsquelle angeschlossen und die 10 Steuerelektroniken an eine separate 5V-Spannungsquelle. Die Minuspole der Spannungsquellen sind verbunden. Beim Einschalten der Stromversorgung „zappeln“ fast alle Servos hin und her und verbrauchen zusammen einen Strom von ca. 3A. Manchmal „zappeln“ nur ein oder zwei Servos, wenn ich die Spannung einschalte. Den/die klemme ich dann ab und alle anderen funktionieren einwandfrei und der Stromverbrauch liegt bei etwa 0,2 – 0,5A.
    Im Voraus bedanke ich mich für Eure Hilfe.

    Gruß Novesia

  2. #2
    Neuer Benutzer Öfters hier
    Registriert seit
    01.11.2005
    Beiträge
    21
    Deine Stromversorgung ist zu schwach ausgelegt. Nimm ein Netzteil das einen grösserer Ausgangsstrom verträgt. Die Servos haben einen hohen Einschaltstrom.

  3. #3
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    24.02.2006
    Ort
    3. Planet eines kleinen Sonnensystems in einem Seitenarm der Milchstraße
    Alter
    63
    Beiträge
    622
    Hi,

    wie Deine Stromquelle ausgelegt ist, wissen wir nicht. Falls 3A < zulässiger (Impuls-)Höchststrom der Stromquelle, könntest Du u.U. einen größeren Kondensator (zusammen mit einem evtl. schon vorhandenen Kondensator sollte die Kapazität mindestens 3000μF betragen) parallel zu Deinen Verbrauchern schalten.
    Bevor Du eine stärkere Spannungsquelle verwendest, könntest Du auch überlegen, ob/wie man die Servos nacheinander einschalten kann.

    Gruß

    Fred
    Only entropy comes easy. - Anton Checkhov

  4. #4
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    19.02.2007
    Beiträge
    210
    Für Servos immer auf 6V gehen

    und bei der modelleisenbahn die spannungen der Servos nur bei betrieb freischalten damit dann der gesamtstrom oder zug impuls am stromerzeuger so gering wie mölich ist
    ein halten des Servos ist normalerweise bei modelleisenbahn nicht notwendig
    es seidenn spur I II wenn die schweren loks kommen

    Die eigenhaltung der Servos sollte ausreichen

  5. #5

    Danke

    Danke,
    an Euch drei für die Tipps.
    Als erstes werde ich eine stärkere Stromquelle verwenden, weil mir der Aufwand dafür am geringsten erscheint; den 7805 / 3A ergänze ich durch einen Leistungstransistor und größere Elkos.
    Da die 10 Servos noch um etwa 30 weitere ergänzt werden, fände ich eine "Nacheinandereinschaltung" etwas aufwändig, aber ich könnte ja die Servos in Gruppen zuschalten.
    Den Strom erst einschalten, wenn der Servo arbeiten soll, werde ich auch mal testen. Wenn der Servo beim Anschalten nicht kurz "zappelt", wäre das auch eine Lösung.

    Ich werde dann von den Ergebnissen berichten, was aber ein paar Tage dauern kann, man muss ja nebenbei auch noch zur Arbeit gehen.

    Gruß Novesia

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •