-
        

Ergebnis 1 bis 4 von 4

Thema: problem mit taster-werte programm

  1. #1
    Neuer Benutzer
    Registriert seit
    28.09.2008
    Ort
    Karlsruhe
    Alter
    22
    Beiträge
    4

    problem mit taster-werte programm

    Anzeige

    SMARTPHONES & TABLETS-bis zu 77% RABATT-Kostenlose Lieferung-Aktuell | Cool | Unentbehrlich
    hallo

    ich hab mir vor kurzem einen asuro gekauft und zusammengelötet. Ich hab jetzt schon ein paar programme geschrieben die auch alle funktioniert haben aba jetzt hab ich ein programm geschrieben dass die taster-werte zurückliefern soll und asuro sendet überhaupt nichts.

    Es wäre nett wenn mir einer von euch helfen könnte.

    Hier ist mein Programm:

    Code:
    #include<asuro.h>
    #include<stdio.h>
    
    int main(){
    	unsigned char taster;
    	char string;
    	Init();
    	
    	while(1){
    		taster = PollSwitch();
    		sprintf(string,"t: %c", taster); 
    		SerWrite(string,5);	
    	}
    return(0);
    }
    also schon mal danke für eure hilfe.

    mfg jojobau
    Hier könnte Ihre Werbung stehen!

  2. #2
    Moderator Robotik Visionär Avatar von radbruch
    Registriert seit
    27.12.2006
    Ort
    Stuttgart
    Alter
    54
    Beiträge
    5.782
    Blog-Einträge
    8
    So vielleicht:
    Code:
    #include "asuro.h"
    #include "stdio.h"
    
    int main(void){
       unsigned char taster;
       char string[5];
       Init();
    
       while(1){
          taster = PollSwitch();
          sprintf(string,"t: %c", taster+'0');
          SerWrite(string,5);
       }
    return(0);
    }

    Atmel’s products are not intended, authorized, or warranted for use
    as components in applications intended to support or sustain life!

  3. #3
    Neuer Benutzer
    Registriert seit
    28.09.2008
    Ort
    Karlsruhe
    Alter
    22
    Beiträge
    4
    danke für die schnelle hilfe aba leider funktioniert es immer noch nicht. Asuro sendet einfach keine zeichen. Weisst du vielleicht woran das liegen könnte
    Hier könnte Ihre Werbung stehen!

  4. #4
    Moderator Robotik Visionär Avatar von radbruch
    Registriert seit
    27.12.2006
    Ort
    Stuttgart
    Alter
    54
    Beiträge
    5.782
    Blog-Einträge
    8
    Hallo

    Asuro sendet einfach keine zeichen.
    Sendet er im Selbsttest? Wird ein simples SerWrite("TEST\n\r", 6); gesendet? Parameter im Terminal richtig eingestellt und Transceiver erkannt (Weisblatttest)?

    Das der asuro nicht sendet ist deshalb sehr verwunderlich weil er beim Fkashen auch aktiv antwortet sonst würde das Flashen abgebrochen werden. Sehr seltsam.

    Gruß

    mic

    Atmel’s products are not intended, authorized, or warranted for use
    as components in applications intended to support or sustain life!

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •