-         

Ergebnis 1 bis 4 von 4

Thema: Probleme bei der instalation von WINAVR

  1. #1

    Probleme bei der instalation von WINAVR

    Anzeige

    Hallo zusammen

    Ich bin ein anfänger der robotik ziemlich interresant findet, drum habe ich mir den RP6 gekauft um zu testen ob das was für mich wäre

    ich habe jedoch leichte startprobleme die Software macht mir probleme

    Habe mir die Neue Version von WinAVR Runtergeladen und installiert, soweit so gut jedoch beim installieren über die konsole von AVR-GCC, avr-libc und avr-binutils die ich ja zusätlich benötige (keine ahnung was das überhaupt sein soll) stell ich mich ziemlich blöd an -.-

    das einzigste was klappt ist:
    > which avr-gcc
    > avr-gcc --version

    da bekomm ich nen pfad und auch die neue version^^


    Ich habe die kompletten ordner von allen drei Programmen in ein Verzeichniss auf C:\RP6 getan (die mann ja später wieder löschen kann)

    Wenn ich nun das automatische script inst. will:
    > cd ~/RP6
    > chmod -x avrgcc_build_and_install.sh
    > ./avrgcc_build_and_install.sh

    muss ich doch anstatt ~ einfach den pfad des verzeichnises angeben in dem die programme liegen oder? z.B
    > cd C:\RP6/RP6

    wäre super falls mir wer helfen könnte, wie ich es korrekt eingeben muss damit ich meinen robby auch mal in action sehe

    mfg Daniel

  2. #2
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    20.08.2008
    Ort
    Karlsruhe
    Alter
    30
    Beiträge
    1.221
    Informier dich mal bitte über Makefiles.
    Ach ja, nochwas: Bist du nun unter Linux oder Windows? WIN_AVR hat aus gutem Grund diesen Namen.
    Unter Linux musst du dir diese Pakete selbst besorgen, in der Regel hat die Distribution die notwendigen Pakete bereits vorkompiliert Paketmanagement.

    mfG
    Markus

  3. #3
    Erfahrener Benutzer Roboter Genie Avatar von SlyD
    Registriert seit
    27.11.2003
    Ort
    Paderborn
    Alter
    33
    Beiträge
    1.514
    Hallo Daniel,

    ehm - lies mal bitte die Installationsanleitung nochmal aufmerksam durch!
    Du vermischst da gerade die Windows Installation mit der Linux Installation. Das steht aber eindeutig dabei was wozu gehört.

    Mehr als WinAVR installieren brauchst Du unter Windows nicht!
    (mal abgesehen von den anderen Sachen wie dem RP6Loader und den Beispielen... )

    MfG,
    SlyD

  4. #4

    Super vielen dank

    Danke euch beiden! hab wirklich Windows mit Linux vermischt und falsch gelesen habs nun hinbekommen zumindest hat schonmal der erste selftest
    Funktioniert nun gehts weiter mit den Beispielprogrammen mal sehn ob das ohne weiteres funktioniert^^


    mfg Daniel

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •