-         

Ergebnis 1 bis 5 von 5

Thema: M2560-Bootloader per AVR-Studio benutzen...

  1. #1
    Erfahrener Benutzer Robotik Einstein Avatar von Jaecko
    Registriert seit
    16.10.2006
    Ort
    Lkr. Rottal/Inn
    Alter
    35
    Beiträge
    1.987

    M2560-Bootloader per AVR-Studio benutzen...

    Anzeige

    SMARTPHONES & TABLETS-bis zu 77% RABATT-Kostenlose Lieferung-Aktuell | Cool | Unentbehrlich
    Moin.

    Zum proggen der ATMegas verwend ich den Bascom-USB-Programmer. D.h. ich schreib den Code im AVR-Studio, erzeug mir da die .hex und lad diese dann in Bascom hoch. Geht, aber ist doch immer ne ziemliche Klickerei.

    Nun hab ich schon den USB-Bootloader von Robotikhardware, der es ja möglich macht, den ATMega2560 über den USB-Port (USART3) zu proggen. Wie bzw. was muss ich jetzt dem AVR-Studio (V4.13) mitteilen, dass er die Software nun so hochlädt?
    Der ATMega wird vom PC als Gerät mit eigenem COM-Port erkannt. Nur wenn ich versuche, irgendeinen Programmer mit diesem COM-Port auszuwählen, beschwert sich AVR-Studio, dass kein Programmer zu finden ist.

    Es soll halt so laufen, wie's bei Bascom und Keil auch möglich ist: F7: Compilieren, F4: Proggen.

    Weiss hier jemand nen Trick?

    mfG
    #ifndef MfG
    #define MfG

  2. #2
    Erfahrener Benutzer Robotik Visionär Avatar von Hubert.G
    Registriert seit
    14.10.2006
    Ort
    Pasching OÖ
    Beiträge
    6.183
    Ich kenne diesen Programmer nicht, aber es würde mich wundern wenn das AVR-Studio diesen nicht erkennt. Probleme kann es mit dem COM-Port geben da das AVR-Studio diese nur bis COM4 akzeptiert. Da müsstest du in der Systemsteuerung eventuell umstellen.
    Auch das STK500 probiert?
    Grüsse Hubert
    ____________

    Meine Projekte findet ihr auf schorsch.at

  3. #3
    Erfahrener Benutzer Robotik Einstein Avatar von Jaecko
    Registriert seit
    16.10.2006
    Ort
    Lkr. Rottal/Inn
    Alter
    35
    Beiträge
    1.987
    Also der USB-Programmer wird vom AVR-Studio definitiv nicht erkannt; ist so ne Extrawurst für Bascom. Was aber da wunderbar funktioniert.

    http://www.shop.robotikhardware.de/s...roducts_id=161

    Com-Port-Technisch hab ichs schon mit COM2 versucht, der ist frei bzw. gehört dem ATMega2560-Modul. Und Programmer hab ich eigentlich alle durchprobiert, die eine Auswahl der COM-Ports bieten. Nur überall heissts, dass kein Programmer (= M2560-Modul) gefunden wird.
    #ifndef MfG
    #define MfG

  4. #4
    Erfahrener Benutzer Robotik Visionär Avatar von Hubert.G
    Registriert seit
    14.10.2006
    Ort
    Pasching OÖ
    Beiträge
    6.183
    Hab es auch gerade in der Info vom Shop gelesen das es nur mit Basom funktioniert.
    Einen Bootloader unterstützt das AVR-Studio meines wissens nicht.
    Ich habe mir den Programmer von www.ullihome.de nachgebaut.
    Grüsse Hubert
    ____________

    Meine Projekte findet ihr auf schorsch.at

  5. #5
    Erfahrener Benutzer Robotik Einstein Avatar von Jaecko
    Registriert seit
    16.10.2006
    Ort
    Lkr. Rottal/Inn
    Alter
    35
    Beiträge
    1.987
    Hm... das mit dem Bootloader ist fast irgendwie schlecht.
    Meine Annahme war die, dass der Bootloader im M2560 nen STK500 simuliert und es dem AVR-Studio somit egal ist, dass das garkein echter STK500 ist.
    #ifndef MfG
    #define MfG

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •