-         

Ergebnis 1 bis 5 von 5

Thema: L298: genaue Funktion des "Motor Stop" (Enable)

  1. #1
    Benutzer Stammmitglied
    Registriert seit
    10.11.2006
    Beiträge
    78

    L298: genaue Funktion des "Motor Stop" (Enable)

    Anzeige

    Hallo,
    bei der Standard-Beschaltung der H-Brücke L298 zeigt sich folgendes Verhalten:
    - input1: high
    - input2: low
    - EnableA: high
    => Motor dreht rechts

    - input1: high
    - input2: low
    - EnableA: low
    => Motor steht

    D.h. am Enable kann z.B. ein PWM-Takt angelegt werden und die Inputs geben die Drehrichtung vor.

    Wie aber ist der im Datenblatt angegebene "Fast Motor Stop" zu verstehen (input1=input2), was passiert da?

    Danke und Gruß

  2. #2
    Moderator Roboter Genie
    Registriert seit
    26.08.2004
    Beiträge
    1.228
    Hi!
    In dem Fall wird wohl die Motorwicklung des Motors über die beiden Inputs kurzgeschlossen. Wenn das passiert wirkt der Motor wie ein Generator mit einem Kurzschluss (bzw. mit großer Last) und wird damit schneller angehalten.

    MfG
    Basti

  3. #3
    Benutzer Stammmitglied
    Registriert seit
    10.11.2006
    Beiträge
    78
    Hallo Basti,
    danke für schnelle Antwort!

    Dann müsste aber doch auch der Strom entsprechend ansteigen und das zeigt das Amperemeter nicht an. Im Gegenteil, der Strom fällt ab. Ärgerlich dass das Datenblatt hier so dürftig ist!

    Frohes Löten wünscht
    Dolfo
    Habe mich derart intensiv eingearbeitet dass ich jetzt fest behaupten kann, ich habe keine Ahnung.

  4. #4
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    06.02.2005
    Ort
    Hamburg
    Alter
    31
    Beiträge
    4.255
    Wo misst du den Strom?
    >In der Versorgungsleitung: hier fließt dann kein Strom mehr, denn beide Motoranschlüsse werden auf ein gemeinsames Potential gelegt.
    >Direkt in der Motorzuleitung: hier fließt der hohe Bremsstrom, allerdings recht kurz, sodass nicht jedes Multimeter was sinnvolles anzeigen dürfte.

  5. #5
    Benutzer Stammmitglied
    Registriert seit
    10.11.2006
    Beiträge
    78
    Hallo Uwe,
    verstehe. Hatte direkt an der Versorgungsleitung gemessen.
    Danke!

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •