-
        

Ergebnis 1 bis 2 von 2

Thema: Problem mit Selbstanregung eines Piezos

  1. #1

    Problem mit Selbstanregung eines Piezos

    Anzeige

    Hey Leute,

    Ich möchte möglichst einfach einen Piezo mit seiner Eigenfrequenz betreiben. Diese sind ja mehr oder minder reine Kapazitäten, wenn sie nicht in Resonanz sind. In Resonanz dagegen dreht sich das ja - ich hab meinen Piezo mal ausgemessen und in Serie betrieben hat er bei 21,43 kHz eine Phase von 0 °, ist also in diesem Moment sozusagen reel. Das kann man ja nutzen, um ihn in dieser Frequenz schwingen zu lassen.

    Dazu gibt es auch diverse Schaltungen. Nur will mein Piezo nicht...

    Ich kann ja mal kurz zeigen, was ich bis dato probiert habe:

    Zuerst hab ich diese Schaltung probiert:

    http://www.pictureupload.de/gallerys...schaltung1.jpg
    Diese hab ich zusammen mit meinem Chef, der zur Zeit nicht da ist, entwickelt.

    Damit hab ich es zwar geschafft, den Quarz zum Oszillieren zu bringen - nur er schwingt abhängig von den Widerständen bei fast jeder Frequenz - außer der Resonanzfrequenz... Ich hab mit R1 die Frequenzen einstellen können. Aber bei so 21 ... 24 kHz wird das System instabil.

    Dann bin ich auf andere Schaltungen umgestiegen, vor allem Piezo-Buzzer-Schaltungen, da ein Piezo-Summer ja normalerweise einfach in seiner Eigenfrequenz schwingt und so den Ton erzeugt.

    Fast das gleiche wie oben ist dann diese Schaltung:
    http://www.pictureupload.de/gallerys...t_difverst.jpg

    dementsprechen das gleiche Ergebnis.

    Zwei nichtinvertierte Verstärker hab ich auch probiert:
    http://www.pictureupload.de/gallerys...vert_verst.jpg

    Da schwingt der Quarz mit 5kHz... Bis dato kA, warum...


    Dann halt Buzzer-Schaltungen. Da hab ich mehrfach eine Schaltung wie hier:
    http://silenceisdefeat.org/~lgtngstk...er/Buzzer.html
    gefunden und mal ausprobiert. Da schwingt mein Piezo gleich mal überhaupt nicht. Aber einen anderen Piezo angeschlossen - der schwingt wiederum bei 40 kHz, was ungefähr hinkommen könnte. Wobei ich die Widerstände anpassen musste - R1=330k, R2=5k, R3=3k9. Hab mehrfach die Anschlüsse der Quarze überprüft. Auch hier bin ich eher planlos, warum der eine schwingt, der andere nicht.

    Dann hab ich jetzt auch mal eine Pierce-Schaltung probiert:
    http://www.pictureupload.de/gallerys...erce-oszi1.jpg
    Auch dort schwingt mein einer Quarz, den ich nicht für die Anwendung verwenden kann, der andere dagegen nicht...

    Sicher kann ich mir im Zweifelsfall einen Oszillator bei 21,43 kHz zusammenbaun und den Piezo anschließen - aber das will ich ja eigentlich gerade nicht. Die sollen sich von selbst einstellen sozusagen. Das wär zur Zeit nur die Notlösung...

    Jede Erklärung oder Idee oder Hilfe oder Schaltung ist mir willkommen, da ich nicht mehr so recht weiter weiß, warum der Piezo nicht so recht will.
    Müsste das eurer Meinung nach funktionieren? Oder mach ich einen Gedankenfehler? Oder ein Problem im Aufbau?

    Danke,
    chr.

  2. #2
    Erfahrener Benutzer Lebende Robotik Legende Avatar von PICture
    Registriert seit
    10.10.2005
    Ort
    Freyung bei Passau in Bayern
    Alter
    66
    Beiträge
    10.970
    Hallo Haqim!

    Ich will nicht die ganze Theorie hier diskutieren, da ich aus Deiner Beschreibung nicht genau weiß was du eigentlich hast Piezoschwinger oder Quarz.

    Probier mal die im Code skizzierte Schaltung. Sie ist mit MOS aufgebaut (z.B. 4069UBP) und kann bis 18V versorgt werden. Vielleicht braucht dein "Schwinger" zum "Starten" höhere Spannung?

    MfG
    Code:
         +----------------------+
         |                  __  |
         |               +-|__|-+
         |           _   |  2M  |
         | |\       | |  | |\   | |\
         +-| >O-||-|| ||-+-| >O-+-| >O->
           |/  8p2  |_|    |/     |/

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •