-         
+ Antworten
Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 18

Thema: HILFE!!! Kann meine AVR´s nicht programmieren

  1. #1
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    05.07.2004
    Ort
    Münchener Osten
    Alter
    43
    Beiträge
    297

    HILFE!!! Kann meine AVR´s nicht programmieren

    Hallo ich habe früher mit den PIC´s gearbeitet und bin jetzt an den AVR´s drann! *lol*

    Jetzt habe ich ein riesen Problem!!!
    Ich habe mir den AVR-IPS Prommer gekauft und mir das BASCOM-AVR besorgt.

    Habe ein kleines Testprogramm geschrieben und will dieses nun auf meinen 90S2313 schreiben.

    Das klappt aber nicht!!!

    Ich habe es vom Bascom aus probiert - geht nicht
    Ich habe es vom ATMEL-Studio 4 probiert - geht nicht
    Ich habe es vom PonyProg probiert - geht nicht

    Zur Schaltung:
    Habe den 90S2313 nur mit einer Stromversorgung versehen und über den 6 Pin - Port mit dem AVRISP Prommer verbunden - es kann also auch nichts stören.

    Brauche ich zum programmieren einen Tackt (Quarz)???


    Wer kann mir helfen???

    Gruß Manuel

  2. #2
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    29.09.2004
    Beiträge
    135
    was heißt "geht nicht" ? kommt da eine Fehlermeldung beim programmieren, oder was passiert ? Hm, ich glaube man muss schon den Quarz haben, da man ja auch zum programmieren den MC an die Stromquelle anschließen muss .... dabei bin ich mir abern icht sicher. Aber wenn du das Programm laufen lassen willst, brauchst du 100% einen Quarz bzw. Takt. Schau mal auf www.mikrocontroller.net da ist ein Schaltplan wie du den 2313 verschalten musst.

  3. #3
    Administrator Robotik Einstein Avatar von Frank
    Registriert seit
    30.10.2003
    Beiträge
    4.943
    Blog-Einträge
    1
    Ja man braucht zum programmieren Quarz

  4. #4
    Gast
    d. h.
    Die mindestbeschaltung zum programmieren ist
    1. CPU
    2. 5V Stromversorgung
    3. TTL Oszi.
    4. ISP Promer

    Ist das so richtig???

    Habe darüber keine Unterlagen gefunden.
    Bei den PIC´s brauche ich zum programmieren keinen Takt, der kommt vom Com-Port.


    Gruß Manuel

  5. #5
    Gast
    Ja so ist es

  6. #6
    Gast
    Nimm beim 2313 keinen 4 Mhz Quarz wenn Du ihn brennen willst. Bei mir streikt der damit grundsätzlich.

  7. #7
    Gast
    Da wird dein Quarz kaputt sein. Bei mir gehts auch mit 4 Mhz!

  8. #8
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    09.08.2004
    Ort
    Potsdam
    Beiträge
    190
    Nee... der ist in Ordnung (hab's mit nem Oszi gesehen).
    Könnte aber sein, das meine Selbstgebaute Programmer-EMV-Dreckschleuder bei der Frequenz irgentwie störend auf die Datenleitungen einkoppelt.

    @MrQu
    Es gibt auch AVR's, die einen internen Taktgenerator besitzen (ausschließlich, oder auch auf extern umschaltbar). Daher solltest Du Dir auf der Atmel-HP die entsprechenden Datenblätter ziehen und vorher reinschauen wie's geht.
    Ist mir auch mal so gegangen.

  9. #9
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    24.01.2004
    Beiträge
    222
    Vielleicht hast du Bascom auch falsch oder gar net eingestellt.
    Frank hat glaub ich n Bild wo man das drauf sieht, wie man Bascom einstellen muss (Sry hab Bascom immo nicht installiert ).

    mfg God

  10. #10
    Gast

+ Antworten
Seite 1 von 2 12 LetzteLetzte

Berechtigungen

  • Neue Themen erstellen: Ja
  • Themen beantworten: Ja
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •