-
        

Ergebnis 1 bis 2 von 2

Thema: Abbruch der IR-Übertragung wegen CRC-Problemen

  1. #1

    Abbruch der IR-Übertragung wegen CRC-Problemen

    Anzeige

    hallo alle miteinander,

    habe erst vor kurzem begonnen mich mit dem asuro zu beschäftigen und stehe nun vor einen merkwürdigem problem beim ir-flashen.

    vorweg:
    der selbsttest funktioniert super, ich verwende den usb-adapter mit dem flash v1.51 unter xp sp2; ob asuro selber eine versions-nr hat konnte ich nicht feststellen (wegen falscher widerstände oder so)

    problem:
    beim flashen des ersten testprogramms entstehen gehäuft crc-probleme, welche spätestens nach der 4ten seite zum abbruch führen; und der repeat übers terminal während des selbsttest funktioniert dementsprechend auch nicht

    meine lösungsversuche sahen wie folgt aus:
    nach einer weile probieren entschloss ich mich die bauteile wieder auszulöten und auf einer steckplatinie zu arangieren zur besseren messung und auch zur abschirmung zwischen asuros ir-sender und ir-empfänger und auch den des usb-adapters, leider alles ohne erfolg meine flash probleme blieben bestehen. unter anderem habe ich ein oszilloskop angeschlossen um zu verfolgen was geschieht und dabei festgestellt, das problem ist, dass asuro "vergisst" das kontrollsignal zu senden nach der seite. der einzige grund der mir einfiel warum, ist, dass das stop-bit der seite beim asuro nicht ankam. ende der geschichte - fragt mich nicht wieso - letztendlich habe ich 8 lagen alu-folie zwischen den usb-adapter und asuro gehalten (ja die ir-"leitung" sozusagen blockiert) und voila übertragung funktioniert reibungslos. keinerlei crc-probleme mehr.

    frage(n):
    wieso hilft die dämpfung des signals tatsächlich? könnte ich die vorwiderstände erhöhen, also hätte das den gleichen effekt, evtl. mit trimmer? wieso habe ich das problem überhaupt? (habe mehrmals den belegungsplan gescheckt und alles scheint ok zu sein)

    bin dankbar über jeden gedankenaustausch, der mir hilft dem misterium auf die schliche zu kommen
    ronnus

  2. #2
    Moderator Robotik Einstein Avatar von damaltor
    Registriert seit
    28.09.2006
    Ort
    Jena
    Alter
    31
    Beiträge
    3.913
    es könnte evtl auch sein, dass du mit der alufolie wirkungsvoll den asuro vor störlicht geschützt hast. die sendedioden sind erstaunlich stark, bei mir reicht es schon den transceiver irgendwo in die nähe des asuro zu legen um zu flashen.

    probier mal das übliche programm: zimmer abdunkeln, alle leuchtstofflampen, energiesparlampen usw abdrehen, bildschirm ausmachen (!) usw. evtl findest du einen übeltäter, der die übertragung stört, und den du zufällig mit der alufolie blockiert hast.
    kleinschreibung ist cool!

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •