-         

Ergebnis 1 bis 4 von 4

Thema: Fusebits RN-Minicontrol

  1. #1

    Fusebits RN-Minicontrol

    Anzeige

    Gut sortiert wie ich bin habe finde ich die Doku-CD zum RN-Minicontrol nicht mehr. Bin ich zu doof oder gibts die Doku nicht online?

    Ich Suche die genaue Beschreibung wie die Lock-/Fusebits für den Atmega168 auf dem Minicontrol gesetzt werden sollen.

    Heute mittag ließ sich dier AVR nichtmehr beschreiben (could not identify ...). Zum Glück hat ein Bekannter so ein ultimaratio-Programmiergerät mit dem wir ihn neu beschrieben haben.
    Ich bin mir zwar relativ sicher, weiß aber nicht ob die Lock/Fusebits so stimmen.
    Das Board funktioniert jetzt wieder, ist aber total langsam. (Fusebit C??)

    Da ich keine Lust habe zu Tippen:





    Nachtrag:
    Was mich interessieren würde ist wie es dazu kam dass der AVR auf einmal nicht mehr wollte.
    Ich war dabei mit dem fertigem Code aus dem Bascom-AVR-Manual zum thema "config keyboard" zu experimentieren.
    Ich habe bis jetzt immer brav die Finger von den Fusebits gelassen, aber plötzlich sagte mir Bascom immer "could not identify...". Wie kommt das?`
    nit resigniert nur reichlich desillusioniert
    e bessje jet hann ich kapiert

  2. #2
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    22.05.2005
    Ort
    12°29´ O, 48°38´ N
    Alter
    48
    Beiträge
    2.731
    Hallo,

    hier wär ein guter Startpunkt:
    http://www.roboternetz.de/wissen/ind...RN-MiniControl
    ganz unten gehts auch weiter zum PDF.
    Im Allgemeinen sollten zu allen RN-Boards die Dokus bei Robotikhardware zu finden sein.
    http://www.robotikhardware.de/

    In Sachen Fusbits, da wird gern das CKDIV8 vergessen, wenns zu langsam ist.
    Dieser hier läuft mit 1MHz internem Takt -> langsam

  3. #3
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    24.02.2006
    Ort
    3. Planet eines kleinen Sonnensystems in einem Seitenarm der Milchstraße
    Alter
    63
    Beiträge
    622
    Hi,

    Zitat Zitat von linux_80
    Dieser hier läuft mit 1MHz internem Takt -> langsam
    zwar weiß ich nicht, mit welcher Frequenz "RN-Minicontrol" laufen soll, aber "linux_80" stellt zu Recht fest, dass die effektive Taktfrequenz aufgrund der gesetzten CKDIV8 Fuse nur 1MHz ist.

    Aber Du fragst, wieso Du Dich vom Flashen "ausgesperrt" haben könntest. Ein beliebter Fehler, der dazu führen kann, ist das Ändern der Fuses für den Systemtakt auf einen externen Quarz (Fall A) oder externen Takteingang (Fall B). ISP geht im Fall A dann nur noch, wenn ein Quarz angeschlossen ist bzw. im Fall B, wenn eine externe Taktquelle anliegt.

    Du zeigst uns ja nur die aktuellen Fuses, mit denen das Flashen funktioniert. Warum es vorher evtl. nicht geklappt hat, kann man nur raten (wie ich im vorigen Absatz).

    Gruß

    Fred
    Only entropy comes easy. - Anton Checkhov

  4. #4
    Danke

    Ursache habe ich gefunden:
    a) meine Dummheit
    b) der Code

    $prog = gefährlich wenn man nicht weiß was man tut.
    Learning by burning (the fusebits) sozusagen.

    Und zu der Onlinedoku kommt wieder meine Dummheit hinzu.
    Ich war auf der Wikiseite zum RN-Minicontrol und habe die Doku gesucht, aber schlichtweg den Link unten übersehen ... naja war zugegeben auch zu müde um klar zu denken.

    Naja man lernt ja bekanntlich auch aus Fehlern


    Und jetzt möge dieser Thred in der ewigen Vergessenheit versinken
    nit resigniert nur reichlich desillusioniert
    e bessje jet hann ich kapiert

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •