-         

Ergebnis 1 bis 5 von 5

Thema: Schaltung mit RN-Control

  1. #1

    Schaltung mit RN-Control

    Anzeige

    SMARTPHONES & TABLETS-bis zu 77% RABATT-Kostenlose Lieferung-Aktuell | Cool | Unentbehrlich
    Hallo leute
    zuerst muss ich sagen RESPEKT, Tolles Forum, Tolle Produkte wie RN-Control

    jetzt zu meinem Problem
    hab seit ein paar Tagen einen RN-Control mit Schrittmotor, und hab soweit geschafft den Schrittmotor zu bewegen usw.

    Jetzt will ich mit dem RN-Control eine schaltung einschalten und ausschalten zu können und hab keine Ahnung wie es realisierbar ist.


    Also ich hab soweit geschafft dass der Motor nach Tastendruck eine bestimmte Drehungen macht.

    Ich hätte gerne nach diese Bewegung eine schaltung einschalten zu können. also es sollte zwei drähte irgendwo am RN-Control mit ein andern verbunden werden.

    Wie ist es möglich?
    Ich hab mir gedacht vielleicht könnte ich durch eine Relais realisieren? und wenn ja wie und welches Model von Relais soll ich verwenden damit ich den RN-Control nicht kaputt mache.

    Danke im Voraus
    LG
    nikta

  2. #2
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    30.07.2007
    Alter
    33
    Beiträge
    214
    Da gibts mehrere gebräuchliche Möglichkeiten:

    - Transistor (BC547 o.ä.) bei Strömen unter 100 mA
    - Reedrelais mit 5V bei Stömen unter 1A (z.B: von Firma MEDER)
    - "Normales" Relais, wobei dann ein Transistor zur Ansteuerung vorgeschaltet werden muss, weil der Spulenwiderstand zu niedrig und der Ansteuerstrom dadurch zu hoch für den ATMega wäre
    - Logic-Level-Mosfet direkt am RN-Control bei Strömen mit mehreren Ampere (abhängig vom Mosfet) z.B. IRLZ34N
    - "Normales" Mosfet über einen Transistor angesteuert für noch höhere Ströme

    Lass am besten mal ein paar Infos zu deinem Motor und der Schaltung die gesteuert werden soll hören, dann kann man gezielter helfen.

    Gruß,

    Cairol

  3. #3
    Hallo und danke vielmals für deine Nachricht.
    Also die Motor-Getriebe werden bipolar gesteuert und hat 5.6 V und 0.85 Ampere, also auf jeden Fall in der empfohlene Grenze von RN-Control. Motor: http://de.nanotec.com/schrittmotor_st4118.html --> ST4118L1206

    Durch Relais sollte eine Kamera auslösen, also es läuft wirklich wenig Strom wenn die Schaltung einmal eingeschaltet worden ist.

    d.h. es wird durch den RN-Control motor einige schritte machen und dann wird der Motor stehen, dann sollte die Kamera auslösen. also bis jetzt habe ich so programmiert dass der Motor die schritte macht und steht und statt auslösen gebe ich jetzt ein BEEP ton an und dann eine Pause und wieder mal von vorn

    also ich nehme an ich muss irgendwo an zwei Pins (eine auf Masse und eine als Schaltpuls) ein Relais einbauen damit wenn ich dort auf eines diesen Pins Strom auf 1 schalte, die Relais eingeschaltet wird und wenn ich es auf 0 setze die Relais "los lässt"

    Also so habe ich mir vorgestellt, aber wie es elektrotechnisch aussieht, habe ich keine Ahnung.


    Würde mich sehr freuen wenn ihr mir dabei helfen könntet

    Edit: habe ins zwischen diesen Artikel bei Conrad gesehen Artikel-Nr.: 504599 - 62, ich glaube damit kann ich mein problem lösen, oder? besteht irgendwie das Gefahr dass ich dabei mein RN-Control kaputt mache?
    ps. wenn ich diesen Relais verwenden kann, wie und wo soll ich es an RN-Control einbauen und wie sollte ich es in Programm ein bzw. ausschalten?

    LG
    nikta

  4. #4
    Hallo
    habe ins zwischen viel exprementiert, aber wirklich nicht viel voran gekommen.

    also ich habe versucht so zu programmieren dass beim Tastendruck eine Subfunktion aufgerunfen wird und die Pina.1 auf 1 gesetzt wird und wieder auf 0, und damit ich überprüfe ob es dort stimmt habe ich die Voltage dort (mit Messgerät) gemessen (also einen Pol auf Pina.1 und eine auf GND) und es zeigt wirklich 4,9 Volt an und wie erwartet wird es dann nach 3 Sekunden runtergesetzt nur es kommt nicht auf 0 sondern 1.5V!!

    Hier das kleine Programm:


    Print "Jetzt wird die Relais in 3 Sekunde geschaltet"
    Waitms 3000
    Porta.1 = 1
    Call Showporta
    Print "Jetzt sollte es an sein"
    Print "Jetzt wird die Relais in 3 Sekunde ausgeschaltet"
    Waitms 3000
    Porta.1 = 0
    Call Showporta

    Jetzt wollte ich es durch eine Glühbirne ausprobieren ob ich damit die Gluhbirne an bzw. ausschalten kann. (Glühbirne hat 4.5V und 0.5 Ampere Verbrauch)

    leider die Gluhbirne wird weder eingeschaltet noch ausgeschaltet, also bin davon ausgegangen dass es nicht genung Ampere da ist, und hab mit Messgerät ampere an diesen Port gemessen, es ist beim Einschalten 123MicroAmpere und beim Ausschalten 0 Ampere, aber interessant ist dass die Spannung beim Einschalten (während ich mit dem Messgerät messe) laut Terminal 0.273704765 Volt und beim Ausschalten 0.273704765 Volt gezeigt wird.

    Ich wäre sehr dankbar wenn mir jemand helfen könnte wie ich diese Schaltung durch eine Relais realisieren kann und welche Relais ich am besten nehmen soll? (evt. beim Conrad weil es mir sehr nah ist)

    Danke im Voraus
    LG
    nikta

  5. #5
    Erfahrener Benutzer Robotik Einstein Avatar von Dirk
    Registriert seit
    30.04.2004
    Ort
    NRW
    Beiträge
    3.791
    Hallo nikta,

    eine typische Schaltung mit Relais sieht so aus, wie in der Abbildung.

    Welches Relais du nimmst, hängt von der Anwendung ab. Hier ist es ein Kleinrelais mit 4..5 V Schaltspannung, so dass (+V) hier an 5V liegt.
    Man kann aber auch an (+V) eine höhere Spannung (z.B. 12V) anlegen, wenn man ein 12V-Relais schalten will.

    Gruß Dirk
    Miniaturansichten angehängter Grafiken Miniaturansichten angehängter Grafiken relais_sp_990.jpg  

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •