-         

Ergebnis 1 bis 3 von 3

Thema: I²C Probleme

  1. #1

    I²C Probleme

    Anzeige

    Wir haben ein I2C (NXP8574) von Conrad. Das Problem stellt sie sich wie folgt dar, wir können den I2C bechreiben und auch die Änderung messen.
    Wenn wir allerdings zurück lesen bekommen wir immer "0" sprich alles Low gemeldet.

    ----------------------------------------------------------------l------------------------------
    define Test byteport[3]
    .
    .
    .
    ' Hier ist IIC111 schon bestückt
    .
    .
    .
    Test=IIC111

    gelesen=Test


    print IIC111 & "-" & gelesen

    ---------------------------------------------------------------------------------------------------------
    Ergebnis: 242 - 0


    Über Anregungen wäre ich sehr dankbar.

  2. #2
    Erfahrener Benutzer Robotik Einstein Avatar von Dirk
    Registriert seit
    30.04.2004
    Ort
    NRW
    Beiträge
    3.791
    Deine Angaben zur Verwendeten Hard- und Software sind so nichtssagend, dass eine Antwort nur mit einer Glaskugel möglich wäre.

    Gruß Dirk

  3. #3
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    22.05.2005
    Ort
    12°29´ O, 48°38´ N
    Alter
    48
    Beiträge
    2.731
    Mit dem C-Control Dingern kenn ich mich ned aus,
    aber beim PCF8574 muss man i.d.R. vor dem einlesen erstmal alle Ausgänge auf 1 setzen, bzw. alle die man nachher einlesen will.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •